summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/groff/groff_1.22.4.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2021-02-18 15:01:03 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-02-19 10:59:57 +0000
commit4449fa226e94f7124215c5ead43aadda7967f3af (patch)
treee5d67d30acc6bd57278deb12d9f7af7fe3604add /meta/recipes-extended/groff/groff_1.22.4.bb
parent22bac8aea0d5d28cc5a3bf20edf638225cce2f88 (diff)
downloadopenembedded-core-contrib-4449fa226e94f7124215c5ead43aadda7967f3af.tar.gz
groff: Fix determinism issue
Sometimes bison would regenerate source files and sometimes it would not This is likely related to the patching of generated files by on of the patches. Drop those changes and force the files to regenerate in all cases since we depend on bison-native anyway. This ensures the results are always consistent. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/groff/groff_1.22.4.bb')
-rw-r--r--meta/recipes-extended/groff/groff_1.22.4.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta/recipes-extended/groff/groff_1.22.4.bb b/meta/recipes-extended/groff/groff_1.22.4.bb
index 0867452ce7..7bb393e09c 100644
--- a/meta/recipes-extended/groff/groff_1.22.4.bb
+++ b/meta/recipes-extended/groff/groff_1.22.4.bb
@@ -18,6 +18,10 @@ SRC_URI = "${GNU_MIRROR}/groff/groff-${PV}.tar.gz \
SRC_URI[md5sum] = "08fb04335e2f5e73f23ea4c3adbf0c5f"
SRC_URI[sha256sum] = "e78e7b4cb7dec310849004fa88847c44701e8d133b5d4c13057d876c1bad0293"
+# Remove at the next upgrade
+PR = "r1"
+HASHEQUIV_HASH_VERSION .= ".1"
+
DEPENDS = "bison-native"
RDEPENDS_${PN} += "perl sed"
@@ -30,6 +34,13 @@ PARALLEL_MAKE = ""
CACHED_CONFIGUREVARS += "ac_cv_path_PERL='/usr/bin/env perl' ac_cv_path_BASH_PROG='no' PAGE=A4"
+# Delete these generated files since we depend on bison-native
+# and regenerate them. Do it deterministically (always).
+do_configure_prepend() {
+ rm -f ${S}/src/preproc/eqn/eqn.cpp
+ rm -f ${S}/src/preproc/eqn/eqn.hpp
+}
+
do_install_append() {
# Some distros have both /bin/perl and /usr/bin/perl, but we set perl location
# for target as /usr/bin/perl, so fix it to /usr/bin/perl.