summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/groff/groff_1.22.4.bb
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2019-05-12 16:16:28 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-05-12 14:17:51 +0100
commit70c2364cae3aad62877e0267d840ea3567d3d1ea (patch)
treee73b6f485fa3942d17d4d7af53235edf076b68dc /meta/recipes-extended/groff/groff_1.22.4.bb
parent68ae5e624642218e7e01805c096da09098a8706f (diff)
downloadopenembedded-core-contrib-70c2364cae3aad62877e0267d840ea3567d3d1ea.tar.gz
groff: upgrade 1.22.3 -> 1.22.4
- Drop groff-1.22.2-correct-man.local-install-path.patch and 0001-Unset-need_charset_alias-when-building-for-musl.patch - Inherit bbclass pkgcnofig to fix `undefined macro: AC_DEFINE' ... | configure:20010: error: possibly undefined macro: AC_DEFINE ... - Use autotools-brokensep to replace autotools to workaround failure caused by out of tree ... | rm -f lib/alloca.h-t lib/alloca.h && \ | { echo '/* DO NOT EDIT! GENERATED AUTOMATICALLY! */'; \ | cat ../groff-1.22.4/lib/alloca.in.h; \ | } > lib/alloca.h-t && \ | mv -f lib/alloca.h-t lib/alloca.h | /bin/sh: line 4: lib/alloca.h-t: No such file or directory | Makefile:10407: recipe for target 'lib/alloca.h' failed ... - Add `--without-doc' to not use target groff to generate doc at build time, since upstream commit [cfe916e Support of configure option to build the documentation.] - Remove groff depends groff-native, and add DEPENDS bison-native - Add 0001-fix-shebang-for-taget.patch - Add 0001-support-musl.patch Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/groff/groff_1.22.4.bb')
-rw-r--r--meta/recipes-extended/groff/groff_1.22.4.bb65
1 files changed, 65 insertions, 0 deletions
diff --git a/meta/recipes-extended/groff/groff_1.22.4.bb b/meta/recipes-extended/groff/groff_1.22.4.bb
new file mode 100644
index 0000000000..37eee9a6cc
--- /dev/null
+++ b/meta/recipes-extended/groff/groff_1.22.4.bb
@@ -0,0 +1,65 @@
+SUMMARY = "GNU Troff software"
+DESCRIPTION = "The groff (GNU troff) software is a typesetting package which reads plain text mixed with \
+formatting commands and produces formatted output."
+SECTION = "base"
+HOMEPAGE = "http://www.gnu.org/software/groff/"
+LICENSE = "GPLv3"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
+
+SRC_URI = "${GNU_MIRROR}/groff/groff-${PV}.tar.gz \
+ file://0001-replace-perl-w-with-use-warnings.patch \
+ file://groff-not-search-fonts-on-build-host.patch \
+ file://0001-fix-shebang-for-taget.patch \
+ file://0001-support-musl.patch \
+"
+
+SRC_URI[md5sum] = "08fb04335e2f5e73f23ea4c3adbf0c5f"
+SRC_URI[sha256sum] = "e78e7b4cb7dec310849004fa88847c44701e8d133b5d4c13057d876c1bad0293"
+
+DEPENDS = "bison-native"
+RDEPENDS_${PN} += "perl sed"
+
+inherit autotools-brokensep texinfo multilib_script pkgconfig
+
+MULTILIB_SCRIPTS = "${PN}:${bindir}/gpinyin ${PN}:${bindir}/groffer ${PN}:${bindir}/grog"
+
+EXTRA_OECONF = "--without-x --without-doc"
+PARALLEL_MAKE = ""
+
+CACHED_CONFIGUREVARS += "ac_cv_path_PERL='/usr/bin/env perl'"
+
+do_install_append() {
+ # Some distros have both /bin/perl and /usr/bin/perl, but we set perl location
+ # for target as /usr/bin/perl, so fix it to /usr/bin/perl.
+ for i in afmtodit mmroff gropdf pdfmom grog; do
+ if [ -f ${D}${bindir}/$i ]; then
+ sed -i -e '1s,#!.*perl,#! ${USRBINPATH}/env perl,' ${D}${bindir}/$i
+ fi
+ done
+ if [ -e ${D}${libdir}/charset.alias ]; then
+ rm -rf ${D}${libdir}/charset.alias
+ fi
+
+ # awk is located at /usr/bin/, not /bin/
+ SPECIAL_AWK=`find ${D} -name special.awk`
+ if [ -f ${SPECIAL_AWK} ]; then
+ sed -i -e 's:#!.*awk:#! ${USRBINPATH}/awk:' ${SPECIAL_AWK}
+ fi
+
+ # not ship /usr/bin/glilypond and its releated files in embedded target system
+ rm -rf ${D}${bindir}/glilypond
+ rm -rf ${D}${libdir}/groff/glilypond
+ rm -rf ${D}${mandir}/man1/glilypond*
+}
+
+do_install_append_class-native() {
+ create_cmdline_wrapper ${D}/${bindir}/groff \
+ -F${STAGING_DIR_NATIVE}${datadir_native}/groff/${PV}/font \
+ -M${STAGING_DIR_NATIVE}${datadir_native}/groff/${PV}/tmac
+}
+
+FILES_${PN} += "${libdir}/${BPN}/site-tmac \
+ ${libdir}/${BPN}/groffer/"
+
+BBCLASSEXTEND = "native"