summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/groff/groff_1.22.3.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-04-10 01:31:27 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-04-11 23:04:25 +0100
commitf516c288d37e53856bce273af2cdbf24f3f5a6e1 (patch)
tree0a21a456b9dcacecc4b3759b788cc6af8b623cfe /meta/recipes-extended/groff/groff_1.22.3.bb
parenta7d8eaef04c9dd6ede8d4efd8c4b776efbe3c767 (diff)
downloadopenembedded-core-contrib-f516c288d37e53856bce273af2cdbf24f3f5a6e1.tar.gz
groff: 1.22.2 -> 1.22.3
* Updated groff-1.22.2-correct-man.local-install-path.patch * Add perl to RDEPENDS_groff since there are a few perl scripts: groff/usr/bin/roff2pdf:#! /usr/bin/env perl groff/usr/bin/afmtodit:#! /usr/bin/env perl -w groff/usr/bin/roff2dvi:#! /usr/bin/env perl groff/usr/bin/roff2text:#! /usr/bin/env perl groff/usr/bin/glilypond:#! /usr/bin/env perl groff/usr/bin/roff2ps:#! /usr/bin/env perl groff/usr/bin/gperl:#! /usr/bin/env perl groff/usr/bin/mmroff:#! /usr/bin/env perl groff/usr/bin/gpinyin:#! /usr/bin/env perl groff/usr/bin/roff2html:#! /usr/bin/env perl groff/usr/bin/grog:#! /usr/bin/env perl groff/usr/bin/gropdf:#! /usr/bin/env perl -w groff/usr/bin/pdfmom:#! /usr/bin/env perl -w groff/usr/bin/chem:#! /usr/bin/env perl groff/usr/bin/roff2x:#! /usr/bin/env perl groff/usr/bin/groffer:#! /usr/bin/env perl groff/usr/lib64/groff/gpinyin/subs.pl:#! /usr/bin/env perl groff/usr/lib64/groff/grog/subs.pl:#! /usr/bin/env perl groff/usr/lib64/groff/groffer/subs.pl:#! /usr/bin/env perl groff/usr/lib64/groff/groffer/man.pl:#! /usr/bin/env perl groff/usr/lib64/groff/groffer/main_subs.pl:#! /usr/bin/env perl * Fix the dangling /usr/bin/perl or /bin/perl for grog. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/groff/groff_1.22.3.bb')
-rw-r--r--meta/recipes-extended/groff/groff_1.22.3.bb67
1 files changed, 67 insertions, 0 deletions
diff --git a/meta/recipes-extended/groff/groff_1.22.3.bb b/meta/recipes-extended/groff/groff_1.22.3.bb
new file mode 100644
index 0000000000..36b221aa1f
--- /dev/null
+++ b/meta/recipes-extended/groff/groff_1.22.3.bb
@@ -0,0 +1,67 @@
+SUMMARY = "GNU Troff software"
+DESCRIPTION = "The groff (GNU troff) software is a typesetting package which reads plain text mixed with \
+formatting commands and produces formatted output."
+SECTION = "base"
+HOMEPAGE = "http://www.gnu.org/software/groff/"
+LICENSE = "GPLv3"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
+
+SRC_URI = "${GNU_MIRROR}/groff/groff-${PV}.tar.gz \
+ file://groff-1.22.2-correct-man.local-install-path.patch \
+"
+
+SRC_URI[md5sum] = "cc825fa64bc7306a885f2fb2268d3ec5"
+SRC_URI[sha256sum] = "3a48a9d6c97750bfbd535feeb5be0111db6406ddb7bb79fc680809cda6d828a5"
+
+DEPENDS = "groff-native"
+DEPENDS_class-native = ""
+
+RDEPENDS_${PN} = "perl"
+
+inherit autotools texinfo
+
+EXTRA_OECONF = "--without-x"
+PARALLEL_MAKE = ""
+
+do_configure_prepend() {
+ if [ "${BUILD_SYS}" != "${HOST_SYS}" ]; then
+ sed -i \
+ -e '/^GROFFBIN=/s:=.*:=${STAGING_BINDIR_NATIVE}/groff:' \
+ -e '/^TROFFBIN=/s:=.*:=${STAGING_BINDIR_NATIVE}/troff:' \
+ -e '/^GROFF_BIN_PATH=/s:=.*:=${STAGING_BINDIR_NATIVE}:' \
+ -e '/^GROFF_BIN_DIR=/s:=.*:=${STAGING_BINDIR_NATIVE}:' \
+ ${S}/contrib/*/Makefile.sub \
+ ${S}/doc/Makefile.in \
+ ${S}/doc/Makefile.sub
+ fi
+}
+
+do_configure_append() {
+ # generate gnulib configure script
+ olddir=`pwd`
+ cd ${S}/src/libs/gnulib/
+ ACLOCAL="$ACLOCAL" autoreconf -Wcross --verbose --install --force ${EXTRA_AUTORECONF} $acpaths || bbfatal "autoreconf execution failed."
+ cd ${olddir}
+}
+
+do_install_append() {
+ # Some distros have both /bin/perl and /usr/bin/perl, but we set perl location
+ # for target as /usr/bin/perl, so fix it to /usr/bin/perl.
+ for i in afmtodit mmroff gropdf pdfmom grog; do
+ if [ -f ${D}${bindir}/$i ]; then
+ sed -i -e '1s,#!.*perl,#! ${USRBINPATH}/env perl,' ${D}${bindir}/$i
+ fi
+ done
+}
+
+do_install_append_class-native() {
+ create_cmdline_wrapper ${D}/${bindir}/groff \
+ -F${STAGING_DIR_NATIVE}${datadir_native}/groff/${PV}/font \
+ -M${STAGING_DIR_NATIVE}${datadir_native}/groff/${PV}/tmac
+}
+
+FILES_${PN} += "${libdir}/${BPN}/site-tmac \
+ ${libdir}/${BPN}/groffer/"
+
+BBCLASSEXTEND = "native"