aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/grep/grep_2.14.bb
diff options
context:
space:
mode:
authorMarko Lindqvist <cazfi74@gmail.com>2012-11-30 18:06:55 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-12-03 14:26:42 +0000
commit53294e7c6e4fabc36f0a6a303bfd0e72808e4b41 (patch)
tree4ef1f8e40e75add7291b71e899098835298fab12 /meta/recipes-extended/grep/grep_2.14.bb
parentab6c778af4333387e742ddab4e690e43de63f204 (diff)
downloadopenembedded-core-contrib-53294e7c6e4fabc36f0a6a303bfd0e72808e4b41.tar.gz
grep: update to upstream version 2.14
Signed-off-by: Marko Lindqvist <cazfi74@gmail.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/grep/grep_2.14.bb')
-rw-r--r--meta/recipes-extended/grep/grep_2.14.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-extended/grep/grep_2.14.bb b/meta/recipes-extended/grep/grep_2.14.bb
new file mode 100644
index 0000000000..386bbd4437
--- /dev/null
+++ b/meta/recipes-extended/grep/grep_2.14.bb
@@ -0,0 +1,41 @@
+SUMMARY = "GNU grep utility"
+DESCRIPTION = "GNU grep utility"
+HOMEPAGE = "http://savannah.gnu.org/projects/grep/"
+BUGTRACKER = "http://savannah.gnu.org/bugs/?group=grep"
+SECTION = "console/utils"
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=8006d9c814277c1bfc4ca22af94b59ee"
+
+PR = "r0"
+
+SRC_URI = "${GNU_MIRROR}/grep/grep-${PV}.tar.xz"
+
+SRC_URI[md5sum] = "d4a3f03849d1e17ce56ab76aa5a24cab"
+SRC_URI[sha256sum] = "e70e801d4fbb16e761654a58ae48bf5020621c95c8e35bd864742577685872e1"
+
+inherit autotools gettext
+
+EXTRA_OECONF = "--disable-perl-regexp"
+
+do_configure_prepend () {
+ rm -f ${S}/m4/init.m4
+}
+
+do_install () {
+ autotools_do_install
+ install -d ${D}${base_bindir}
+ mv ${D}${bindir}/grep ${D}${base_bindir}/grep
+ mv ${D}${bindir}/egrep ${D}${base_bindir}/egrep
+ mv ${D}${bindir}/fgrep ${D}${base_bindir}/fgrep
+ rmdir ${D}${bindir}/
+}
+
+inherit update-alternatives
+
+ALTERNATIVE_PRIORITY = "100"
+
+ALTERNATIVE_${PN} = "grep egrep fgrep"
+ALTERNATIVE_LINK_NAME[grep] = "${base_bindir}/grep"
+ALTERNATIVE_LINK_NAME[egrep] = "${base_bindir}/egrep"
+ALTERNATIVE_LINK_NAME[fgrep] = "${base_bindir}/fgrep"
+