aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ghostscript
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-11-25 13:10:41 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-11-27 10:25:33 +0000
commitb06b1b0811bea6ba5ed04f28c06be0f404924cc5 (patch)
tree3ff7ba7956864c956ff66c915e7599becdc5dc31 /meta/recipes-extended/ghostscript
parentd7db3680ba7af1a5c56a19d8db32873a2784016b (diff)
downloadopenembedded-core-contrib-b06b1b0811bea6ba5ed04f28c06be0f404924cc5.tar.gz
ghostscript: Really fix parallel make race
There continue to be parallel make race issues showing up on the autobuilder. This patch removes some potential sources of these. The rm is unrequired since we're using cp -f. The || true ensures that if we did race against someone it becomes harmless. [YOCTO #1202] (From OE-Core rev: 32840cd95fcde92433fbb0271b82d0f4048a823a) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/ghostscript')
-rw-r--r--meta/recipes-extended/ghostscript/ghostscript/ghostscript-9.02-parallel-make.patch19
-rw-r--r--meta/recipes-extended/ghostscript/ghostscript_9.04.bb2
2 files changed, 20 insertions, 1 deletions
diff --git a/meta/recipes-extended/ghostscript/ghostscript/ghostscript-9.02-parallel-make.patch b/meta/recipes-extended/ghostscript/ghostscript/ghostscript-9.02-parallel-make.patch
index 76d167650d..bb0c41c40c 100644
--- a/meta/recipes-extended/ghostscript/ghostscript/ghostscript-9.02-parallel-make.patch
+++ b/meta/recipes-extended/ghostscript/ghostscript/ghostscript-9.02-parallel-make.patch
@@ -4,6 +4,8 @@ http://bugzilla.pokylinux.org/show_bug.cgi?id=1202
Upstream-Status: Pending
Signed-off-by: Kang Kai <kai.kang@windriver.com>
+
+RP: Tweaked to include lib.mak fixes
--- ghostscript-9.02/base/unixhead.mak.orig 2011-07-27 17:06:17.749456100 +0800
+++ ghostscript-9.02/base/unixhead.mak 2011-07-27 17:06:37.449456100 +0800
@@ -54,7 +54,7 @@
@@ -15,3 +17,20 @@ Signed-off-by: Kang Kai <kai.kang@windriver.com>
RM_=rm -f
RMN_=rm -f
+Index: ghostscript-9.04/base/lib.mak
+===================================================================
+--- ghostscript-9.04.orig/base/lib.mak 2011-11-25 13:06:21.728502636 +0000
++++ ghostscript-9.04/base/lib.mak 2011-11-25 13:08:33.924504957 +0000
+@@ -592,10 +592,8 @@
+ $(gscdefs_h) $(gconf_h)\
+ $(gxdevice_h) $(gxiclass_h) $(gxiodev_h) $(gxiparam_h) $(TOP_MAKEFILES)\
+ $(MAKEDDIRS)
+- $(RM_) $(GLGEN)gconfig.c
+- $(RM_) $(GLGEN)gconfig.h
+- $(CP_) $(gconfig_h) $(GLGEN)gconfig.h
+- $(CP_) $(GLSRC)gconf.c $(GLGEN)gconfig.c
++ $(CP_) $(gconfig_h) $(GLGEN)gconfig.h || true
++ $(CP_) $(GLSRC)gconf.c $(GLGEN)gconfig.c || true
+ $(GLCC) $(GLO_)gconfig.$(OBJ) $(C_) $(GLGEN)gconfig.c
+
+ $(GLOBJ)gscdefs.$(OBJ) : $(GLSRC)gscdef.c\
diff --git a/meta/recipes-extended/ghostscript/ghostscript_9.04.bb b/meta/recipes-extended/ghostscript/ghostscript_9.04.bb
index dba92e9aba..d4448109bb 100644
--- a/meta/recipes-extended/ghostscript/ghostscript_9.04.bb
+++ b/meta/recipes-extended/ghostscript/ghostscript_9.04.bb
@@ -15,7 +15,7 @@ SECTION = "console/utils"
LICENSE = "GPLv3"
LIC_FILES_CHKSUM = "file://LICENSE;md5=d151214b3131251dfc9d858593acbd24"
-PR = "r0"
+PR = "r1"
DEPENDS = "ghostscript-native tiff jpeg fontconfig cups"
DEPENDS_virtclass-native = ""