aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/gawk/gawk_4.1.3.bb
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2015-06-01 17:44:13 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-06-03 16:34:32 +0100
commit491d485ade68c128624eee00977f293dba8f64b9 (patch)
tree57dc43e92535e46650007907ef8059d44d8eebd0 /meta/recipes-extended/gawk/gawk_4.1.3.bb
parentd024a53c8018d63348b5939cdec1ba1b34356cb4 (diff)
downloadopenembedded-core-contrib-491d485ade68c128624eee00977f293dba8f64b9.tar.gz
gawk: upgrade to 4.1.3
The following two patches are removed because they have been merged in the new version. Use-DESTDIR-in-extension-Makefile.am-when-removing-..patch extension-Add-DESTDIR-prefix-to-remaining-pkgextensi.patch Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-extended/gawk/gawk_4.1.3.bb')
-rw-r--r--meta/recipes-extended/gawk/gawk_4.1.3.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta/recipes-extended/gawk/gawk_4.1.3.bb b/meta/recipes-extended/gawk/gawk_4.1.3.bb
new file mode 100644
index 0000000000..d1a88e45a9
--- /dev/null
+++ b/meta/recipes-extended/gawk/gawk_4.1.3.bb
@@ -0,0 +1,47 @@
+SUMMARY = "GNU awk text processing utility"
+DESCRIPTION = "The GNU version of awk, a text processing utility. \
+Awk interprets a special-purpose programming language to do \
+quick and easy text pattern matching and reformatting jobs."
+HOMEPAGE = "https://www.gnu.org/software/gawk/"
+BUGTRACKER = "bug-gawk@gnu.org"
+SECTION = "console/utils"
+
+# gawk <= 3.1.5: GPLv2
+# gawk >= 3.1.6: GPLv3
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
+
+DEPENDS += "readline"
+
+PACKAGECONFIG[mpfr] = "--with-mpfr,--without-mpfr, mpfr"
+
+SRC_URI = "${GNU_MIRROR}/gawk/gawk-${PV}.tar.gz \
+ file://run-ptest \
+"
+
+SRC_URI[md5sum] = "55d37f4069502677f25d1340df8eec97"
+SRC_URI[sha256sum] = "524effa5b9ecd4ed940f2581c5d3c1df4e4bd7e6f768aa033c1916f47dfc6e29"
+
+inherit autotools gettext texinfo update-alternatives
+
+FILES_${PN} += "${datadir}/awk"
+FILES_${PN}-dev += "${libdir}/${BPN}/*.la"
+FILES_${PN}-dbg += "${libexecdir}/awk/.debug"
+
+ALTERNATIVE_${PN} = "awk"
+ALTERNATIVE_TARGET[awk] = "${bindir}/gawk"
+ALTERNATIVE_PRIORITY = "100"
+
+do_install_append() {
+ # remove the link since we don't package it
+ rm ${D}${bindir}/awk
+}
+
+inherit ptest
+
+do_install_ptest() {
+ mkdir ${D}${PTEST_PATH}/test
+ for i in `grep -vE "@|^$|#|Gt-dummy" ${S}/test/Maketests |awk -F: '{print $1}'` Maketests; \
+ do cp ${S}/test/$i* ${D}${PTEST_PATH}/test; \
+ done
+}