summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ethtool/ethtool_5.8.bb
diff options
context:
space:
mode:
authorChanghyeok Bae <changhyeok.bae@gmail.com>2020-08-19 16:49:43 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-08-20 15:28:57 +0100
commitbc037110fc53b34db7073b7c17fd715b30651a9e (patch)
tree6932a34e5aa80fb181752fb0d357f3a07f9638d9 /meta/recipes-extended/ethtool/ethtool_5.8.bb
parenta38527357f4255f0f4cf888f640f38f2ef5942e0 (diff)
downloadopenembedded-core-contrib-bc037110fc53b34db7073b7c17fd715b30651a9e.tar.gz
ethtool: upgrade 5.7 -> 5.8
test-features is only generated without netlink configuration. Signed-off-by: Changhyeok Bae <changhyeok.bae@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/ethtool/ethtool_5.8.bb')
-rw-r--r--meta/recipes-extended/ethtool/ethtool_5.8.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-extended/ethtool/ethtool_5.8.bb b/meta/recipes-extended/ethtool/ethtool_5.8.bb
new file mode 100644
index 0000000000..0403f0e3a9
--- /dev/null
+++ b/meta/recipes-extended/ethtool/ethtool_5.8.bb
@@ -0,0 +1,37 @@
+SUMMARY = "Display or change ethernet card settings"
+DESCRIPTION = "A small utility for examining and tuning the settings of your ethernet-based network interfaces."
+HOMEPAGE = "http://www.kernel.org/pub/software/network/ethtool/"
+SECTION = "console/network"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
+ file://ethtool.c;beginline=4;endline=17;md5=c19b30548c582577fc6b443626fc1216"
+
+SRC_URI = "${KERNELORG_MIRROR}/software/network/ethtool/ethtool-${PV}.tar.gz \
+ file://run-ptest \
+ file://avoid_parallel_tests.patch \
+ "
+
+SRC_URI[sha256sum] = "91e8bbda48a7fd5d374efacca542364ceb3a6c1f286f024b64ec40ccc799e125"
+
+UPSTREAM_CHECK_URI = "https://www.kernel.org/pub/software/network/ethtool/"
+
+inherit autotools ptest bash-completion pkgconfig
+
+RDEPENDS_${PN}-ptest += "make"
+
+PACKAGECONFIG ?= "netlink"
+PACKAGECONFIG[netlink] = "--enable-netlink,--disable-netlink,libmnl,"
+
+do_compile_ptest() {
+ oe_runmake buildtest-TESTS
+}
+
+do_install_ptest () {
+ cp ${B}/Makefile ${D}${PTEST_PATH}
+ install ${B}/test-cmdline ${D}${PTEST_PATH}
+ if ${@bb.utils.contains('PACKAGECONFIG', 'netlink', 'false', 'true', d)}; then
+ install ${B}/test-features ${D}${PTEST_PATH}
+ fi
+ install ${B}/ethtool ${D}${PTEST_PATH}/ethtool
+ sed -i 's/^Makefile/_Makefile/' ${D}${PTEST_PATH}/Makefile
+}