summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ethtool/ethtool_4.2.bb
diff options
context:
space:
mode:
authorMaxin B. John <maxin.john@intel.com>2015-11-12 10:53:22 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-11-25 07:56:50 +0000
commitc3950647a3a84986380cc37d4a1dfbacc1c0acc6 (patch)
tree1729cd0a083b4d49d5af8abc1a8c31517268bf71 /meta/recipes-extended/ethtool/ethtool_4.2.bb
parent928adfc807d3c812fcd748e2cf65f392eebd852c (diff)
downloadopenembedded-core-contrib-c3950647a3a84986380cc37d4a1dfbacc1c0acc6.tar.gz
ethtool: bump version to 4.2
4.0 -> 4.2 Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-extended/ethtool/ethtool_4.2.bb')
-rw-r--r--meta/recipes-extended/ethtool/ethtool_4.2.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-extended/ethtool/ethtool_4.2.bb b/meta/recipes-extended/ethtool/ethtool_4.2.bb
new file mode 100644
index 0000000000..95df784c4c
--- /dev/null
+++ b/meta/recipes-extended/ethtool/ethtool_4.2.bb
@@ -0,0 +1,30 @@
+SUMMARY = "Display or change ethernet card settings"
+DESCRIPTION = "A small utility for examining and tuning the settings of your ethernet-based network interfaces."
+HOMEPAGE = "http://www.kernel.org/pub/software/network/ethtool/"
+SECTION = "console/network"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
+ file://ethtool.c;beginline=4;endline=17;md5=c19b30548c582577fc6b443626fc1216"
+
+SRC_URI = "${KERNELORG_MIRROR}/software/network/ethtool/ethtool-${PV}.tar.gz \
+ file://run-ptest \
+ file://avoid_parallel_tests.patch \
+ "
+
+SRC_URI[md5sum] = "5b55f7cd76e901dfc2738ac22cab96ca"
+SRC_URI[sha256sum] = "f84226db8dd18afaf91d8d00f5cb8f87ec3d7f787d2a3605de08d6dfa95ab8ef"
+
+inherit autotools ptest
+RDEPENDS_${PN}-ptest += "make"
+
+do_compile_ptest() {
+ oe_runmake buildtest-TESTS
+}
+
+do_install_ptest () {
+ cp ${B}/Makefile ${D}${PTEST_PATH}
+ install ${B}/test-cmdline ${D}${PTEST_PATH}
+ install ${B}/test-features ${D}${PTEST_PATH}
+ install ${B}/ethtool ${D}${PTEST_PATH}/ethtool
+ sed -i 's/^Makefile/_Makefile/' ${D}${PTEST_PATH}/Makefile
+}