aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ethtool/ethtool_4.19.bb
diff options
context:
space:
mode:
authorChanghyeok Bae <changhyeok.bae@gmail.com>2018-11-22 01:48:30 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-01-08 20:12:02 +0000
commit4bcacd05428498158ae2fedc11bf4d6f11824967 (patch)
tree2acf5f1828c0e5197f2c4455e1d76d41977472cb /meta/recipes-extended/ethtool/ethtool_4.19.bb
parent875ebdcaf479b38f7564d68f1530de08e50f8ba8 (diff)
downloadopenembedded-core-contrib-4bcacd05428498158ae2fedc11bf4d6f11824967.tar.gz
ethtool: 4.17 -> 4.19
(From OE-Core rev: 565bbbf43da14de466fccdfaa259bdb9b50b686e) Signed-off-by: Changhyeok Bae <changhyeok.bae@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta/recipes-extended/ethtool/ethtool_4.19.bb')
-rw-r--r--meta/recipes-extended/ethtool/ethtool_4.19.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-extended/ethtool/ethtool_4.19.bb b/meta/recipes-extended/ethtool/ethtool_4.19.bb
new file mode 100644
index 0000000000..74e255c24b
--- /dev/null
+++ b/meta/recipes-extended/ethtool/ethtool_4.19.bb
@@ -0,0 +1,30 @@
+SUMMARY = "Display or change ethernet card settings"
+DESCRIPTION = "A small utility for examining and tuning the settings of your ethernet-based network interfaces."
+HOMEPAGE = "http://www.kernel.org/pub/software/network/ethtool/"
+SECTION = "console/network"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
+ file://ethtool.c;beginline=4;endline=17;md5=c19b30548c582577fc6b443626fc1216"
+
+SRC_URI = "${KERNELORG_MIRROR}/software/network/ethtool/ethtool-${PV}.tar.gz \
+ file://run-ptest \
+ file://avoid_parallel_tests.patch \
+ "
+
+SRC_URI[md5sum] = "a533db1d202724822c4ef297643fac12"
+SRC_URI[sha256sum] = "e8e88f5a79c78e542cd84fee60b67dbf29cee63e4760e8d61544fea74c761ad1"
+
+inherit autotools ptest
+RDEPENDS_${PN}-ptest += "make"
+
+do_compile_ptest() {
+ oe_runmake buildtest-TESTS
+}
+
+do_install_ptest () {
+ cp ${B}/Makefile ${D}${PTEST_PATH}
+ install ${B}/test-cmdline ${D}${PTEST_PATH}
+ install ${B}/test-features ${D}${PTEST_PATH}
+ install ${B}/ethtool ${D}${PTEST_PATH}/ethtool
+ sed -i 's/^Makefile/_Makefile/' ${D}${PTEST_PATH}/Makefile
+}