aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ethtool/ethtool_4.0.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-06-02 02:55:28 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-06-03 16:38:11 +0100
commit0a5bb9f617dffbfddf599555cff5f5536f10b93f (patch)
tree7501d027de828079f0fdf77810010c3d86df2b4d /meta/recipes-extended/ethtool/ethtool_4.0.bb
parentd713080a3299de2d5bffaed7469b1cb9ae1ca107 (diff)
downloadopenembedded-core-contrib-0a5bb9f617dffbfddf599555cff5f5536f10b93f.tar.gz
ethtool: 3.16 -> 4.0
Removed ethtool-uint.patch since it is already in the source. Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Diffstat (limited to 'meta/recipes-extended/ethtool/ethtool_4.0.bb')
-rw-r--r--meta/recipes-extended/ethtool/ethtool_4.0.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-extended/ethtool/ethtool_4.0.bb b/meta/recipes-extended/ethtool/ethtool_4.0.bb
new file mode 100644
index 0000000000..13f2b1cf56
--- /dev/null
+++ b/meta/recipes-extended/ethtool/ethtool_4.0.bb
@@ -0,0 +1,30 @@
+SUMMARY = "Display or change ethernet card settings"
+DESCRIPTION = "A small utility for examining and tuning the settings of your ethernet-based network interfaces."
+HOMEPAGE = "http://www.kernel.org/pub/software/network/ethtool/"
+SECTION = "console/network"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
+ file://ethtool.c;beginline=4;endline=17;md5=c19b30548c582577fc6b443626fc1216"
+
+SRC_URI = "${KERNELORG_MIRROR}/software/network/ethtool/ethtool-${PV}.tar.gz \
+ file://run-ptest \
+ file://avoid_parallel_tests.patch \
+ "
+
+SRC_URI[md5sum] = "0a1c78787c7dcf077016ed86372a472f"
+SRC_URI[sha256sum] = "e200516727cc9583e8b63fd6e72f667f9ed41bb4f0577ff4803b60c64cfd1dbc"
+
+inherit autotools ptest
+RDEPENDS_${PN}-ptest += "make"
+
+do_compile_ptest() {
+ oe_runmake buildtest-TESTS
+}
+
+do_install_ptest () {
+ cp ${B}/Makefile ${D}${PTEST_PATH}
+ install ${B}/test-cmdline ${D}${PTEST_PATH}
+ install ${B}/test-features ${D}${PTEST_PATH}
+ install ${B}/ethtool ${D}${PTEST_PATH}/ethtool
+ sed -i 's/^Makefile/_Makefile/' ${D}${PTEST_PATH}/Makefile
+}