aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/cracklib/cracklib_2.9.5.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-07-27 02:09:23 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-07-31 10:31:02 +0100
commit466dcc8358f3bd041854084fc6c0eb55a830342f (patch)
treeefa78767257fa7014efeb2b07c694b18a2e85129 /meta/recipes-extended/cracklib/cracklib_2.9.5.bb
parent448f658d758174b64891e552fd88ff0a10afbf5e (diff)
downloadopenembedded-core-contrib-466dcc8358f3bd041854084fc6c0eb55a830342f.tar.gz
cracklib: 2.9.4 -> 2.9.5
Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-extended/cracklib/cracklib_2.9.5.bb')
-rw-r--r--meta/recipes-extended/cracklib/cracklib_2.9.5.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta/recipes-extended/cracklib/cracklib_2.9.5.bb b/meta/recipes-extended/cracklib/cracklib_2.9.5.bb
new file mode 100644
index 0000000000..c0ffe33160
--- /dev/null
+++ b/meta/recipes-extended/cracklib/cracklib_2.9.5.bb
@@ -0,0 +1,45 @@
+SUMMARY = "Password strength checker library"
+HOMEPAGE = "http://sourceforge.net/projects/cracklib"
+
+LICENSE = "LGPLv2.1+"
+LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=e3eda01d9815f8d24aae2dbd89b68b06"
+
+DEPENDS = "cracklib-native zlib python"
+RDEPEND_${PN}-python += "python"
+
+PACKAGES += "${PN}-python"
+
+EXTRA_OECONF = "--with-python --libdir=${base_libdir}"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/cracklib/cracklib-${PV}.tar.gz \
+ file://0001-packlib.c-support-dictionary-byte-order-dependent.patch \
+ file://0002-craklib-fix-testnum-and-teststr-failed.patch"
+
+SRC_URI[md5sum] = "376790a95c1fb645e59e6e9803c78582"
+SRC_URI[sha256sum] = "59ab0138bc8cf90cccb8509b6969a024d5e58d2d02bcbdccbb9ba9b88be3fa33"
+
+inherit autotools gettext pythonnative python-dir
+
+do_install_append_class-target() {
+ create-cracklib-dict -o ${D}${datadir}/cracklib/pw_dict ${D}${datadir}/cracklib/cracklib-small
+}
+
+do_install_append() {
+ src_dir="${D}${base_libdir}/${PYTHON_DIR}/site-packages"
+ rm -f $src_dir/*.pyo
+ rm -f $src_dir/test_cracklib.py
+ # Move python files from ${base_libdir} to ${libdir} since used --libdir=${base_libdir}
+ install -d -m 0755 ${D}${PYTHON_SITEPACKAGES_DIR}/
+ mv $src_dir/* ${D}${PYTHON_SITEPACKAGES_DIR}
+ rm -fr ${D}${base_libdir}/${PYTHON_DIR}
+}
+
+BBCLASSEXTEND = "native nativesdk"
+
+FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}/cracklib.py \
+ ${PYTHON_SITEPACKAGES_DIR}/_cracklib.so \
+ "
+FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/.debug/_cracklib.so"
+FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/_cracklib.a \
+ ${PYTHON_SITEPACKAGES_DIR}/_cracklib.la \
+ "