summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/bc/bc_1.07.1.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-07-17 17:38:56 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-07-24 11:52:07 +0100
commit9862849ba883c110e4d2c57c39ab2c58e9b2d216 (patch)
tree428355282174d2da9ce27dd89d0d3adbe920b1f2 /meta/recipes-extended/bc/bc_1.07.1.bb
parent43be374a6deceeaf105794f034957c65bb6bec72 (diff)
downloadopenembedded-core-contrib-9862849ba883c110e4d2c57c39ab2c58e9b2d216.tar.gz
bc: upgrade to 1.07.1
Relicensed to just GPLv3+, update LICENSE and checksums. The build dependency for flex should be flex-native. libmath.h is missing from the tarball (it was present in 1.06) and the generation rules are not cross-friendly, so delete the rules and copy in a pre-generated libmath.h. Remove fix-segment-fault.patch as the fixes are now upstream. Add PACKAGECONFIG for readline and libedit, defaulting to readline. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/bc/bc_1.07.1.bb')
-rw-r--r--meta/recipes-extended/bc/bc_1.07.1.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-extended/bc/bc_1.07.1.bb b/meta/recipes-extended/bc/bc_1.07.1.bb
new file mode 100644
index 0000000000..e80857745e
--- /dev/null
+++ b/meta/recipes-extended/bc/bc_1.07.1.bb
@@ -0,0 +1,33 @@
+SUMMARY = "Arbitrary precision calculator language"
+HOMEPAGE = "http://www.gnu.org/software/bc/bc.html"
+
+LICENSE = "GPLv3+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
+ file://COPYING.LIB;md5=6a6a8e020838b23406c81b19c1d46df6 \
+ file://bc/bcdefs.h;endline=17;md5=4295c06df9e833519a342f7b5d43db06 \
+ file://dc/dc.h;endline=18;md5=36b8c600b63ee8c3aeade2764f6b2a4b \
+ file://lib/number.c;endline=20;md5=cf43068cc88f837731dc53240456cfaf"
+
+SECTION = "base"
+DEPENDS = "flex-native"
+
+SRC_URI = "${GNU_MIRROR}/${BPN}/${BP}.tar.gz \
+ file://no-gen-libmath.patch \
+ file://libmath.h"
+SRC_URI[md5sum] = "cda93857418655ea43590736fc3ca9fc"
+SRC_URI[sha256sum] = "62adfca89b0a1c0164c2cdca59ca210c1d44c3ffc46daf9931cf4942664cb02a"
+
+inherit autotools texinfo update-alternatives
+
+PACKAGECONFIG ??= "readline"
+PACKAGECONFIG[readline] = "--with-readline,--without-readline,readline"
+PACKAGECONFIG[libedit] = "--with-libedit,--without-libedit,libedit"
+
+do_compile_prepend() {
+ cp -f ${WORKDIR}/libmath.h ${B}/bc/libmath.h
+}
+
+ALTERNATIVE_${PN} = "dc"
+ALTERNATIVE_PRIORITY = "100"
+
+BBCLASSEXTEND = "native" \ No newline at end of file