aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/bc/bc/no-gen-libmath.patch
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-07-17 17:38:56 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-07-24 11:52:07 +0100
commit9862849ba883c110e4d2c57c39ab2c58e9b2d216 (patch)
tree428355282174d2da9ce27dd89d0d3adbe920b1f2 /meta/recipes-extended/bc/bc/no-gen-libmath.patch
parent43be374a6deceeaf105794f034957c65bb6bec72 (diff)
downloadopenembedded-core-contrib-9862849ba883c110e4d2c57c39ab2c58e9b2d216.tar.gz
bc: upgrade to 1.07.1
Relicensed to just GPLv3+, update LICENSE and checksums. The build dependency for flex should be flex-native. libmath.h is missing from the tarball (it was present in 1.06) and the generation rules are not cross-friendly, so delete the rules and copy in a pre-generated libmath.h. Remove fix-segment-fault.patch as the fixes are now upstream. Add PACKAGECONFIG for readline and libedit, defaulting to readline. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/bc/bc/no-gen-libmath.patch')
-rw-r--r--meta/recipes-extended/bc/bc/no-gen-libmath.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-extended/bc/bc/no-gen-libmath.patch b/meta/recipes-extended/bc/bc/no-gen-libmath.patch
new file mode 100644
index 0000000000..c4cce58759
--- /dev/null
+++ b/meta/recipes-extended/bc/bc/no-gen-libmath.patch
@@ -0,0 +1,24 @@
+These rules are not cross-friendly so delete them and we'll generate the file offline.
+
+Upstream-Status: Inappropriate
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+diff --git a/bc/Makefile.am b/bc/Makefile.am
+index d9d412e..f244241 100644
+--- a/bc/Makefile.am
++++ b/bc/Makefile.am
+@@ -31,14 +31,6 @@ global.o: libmath.h
+
+ fbcOBJ = main.o bc.o scan.o execute.o load.o storage.o util.o warranty.o
+
+-libmath.h: libmath.b $(fbcOBJ) $(LIBBC)
+- echo '{0}' > libmath.h
+- $(MAKE) global.o
+- $(LINK) -o fbc $(fbcOBJ) global.o $(LIBBC) $(LIBL) $(READLINELIB) $(LIBS)
+- ./fbc -c $(srcdir)/libmath.b </dev/null >libmath.h
+- $(srcdir)/fix-libmath_h
+- rm -f ./fbc ./global.o
+-
+ sbcOBJ = main.o sbc.o scan.o execute.o global.o load.o storage.o util.o \
+ warranty.o
+ sbc.o: sbc.c