summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/acpica/acpica_20201113.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-12-04 21:07:25 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-12-09 12:15:17 +0000
commit44477d30f7220f424c3d9f28efb84e157b89c89f (patch)
tree6422c4d024f87bffd54b3eb605fe5ad6b0b307bb /meta/recipes-extended/acpica/acpica_20201113.bb
parent5b4087ed13ac042ed46f6c0592db7742895f9020 (diff)
downloadopenembedded-core-contrib-44477d30f7220f424c3d9f28efb84e157b89c89f.tar.gz
acpica: upgrade 20200925 -> 20201113
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/acpica/acpica_20201113.bb')
-rw-r--r--meta/recipes-extended/acpica/acpica_20201113.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-extended/acpica/acpica_20201113.bb b/meta/recipes-extended/acpica/acpica_20201113.bb
new file mode 100644
index 0000000000..f2d17ca54e
--- /dev/null
+++ b/meta/recipes-extended/acpica/acpica_20201113.bb
@@ -0,0 +1,49 @@
+SUMMARY = "ACPICA tools for the development and debug of ACPI tables"
+DESCRIPTION = "The ACPI Component Architecture (ACPICA) project provides an \
+OS-independent reference implementation of the Advanced Configuration and \
+Power Interface Specification (ACPI). ACPICA code contains those portions of \
+ACPI meant to be directly integrated into the host OS as a kernel-resident \
+subsystem, and a small set of tools to assist in developing and debugging \
+ACPI tables."
+
+HOMEPAGE = "http://www.acpica.org/"
+SECTION = "console/tools"
+
+LICENSE = "Intel | BSD | GPLv2"
+LIC_FILES_CHKSUM = "file://source/compiler/aslcompile.c;beginline=7;endline=150;md5=6adbcb81e9ee6ae50c569b94fe12f7c5"
+
+COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
+
+DEPENDS = "m4-native flex-native bison-native"
+
+SRC_URI = "https://acpica.org/sites/acpica/files/acpica-unix-${PV}.tar.gz"
+SRC_URI[sha256sum] = "48c4e0c07b42581d017487cc9264470e6420605ddd24cbb5d16410d02a771461"
+
+UPSTREAM_CHECK_URI = "https://acpica.org/downloads"
+
+S = "${WORKDIR}/acpica-unix-${PV}"
+
+inherit update-alternatives
+
+ALTERNATIVE_PRIORITY = "100"
+ALTERNATIVE_${PN} = "acpixtract acpidump"
+
+EXTRA_OEMAKE = "CC='${CC}' \
+ OPT_CFLAGS=-Wall \
+ DESTDIR=${D} \
+ PREFIX=${prefix} \
+ INSTALLDIR=${bindir} \
+ INSTALLFLAGS= \
+ "
+
+do_install() {
+ oe_runmake install
+}
+
+# iasl*.bb is a subset of this recipe, so RREPLACE it
+PROVIDES = "iasl"
+RPROVIDES_${PN} += "iasl"
+RREPLACES_${PN} += "iasl"
+RCONFLICTS_${PN} += "iasl"
+
+BBCLASSEXTEND = "native"