summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2020-06-09 21:52:10 +0800
committerSteve Sakoman <steve@sakoman.com>2020-12-11 06:16:48 -1000
commitcaf6dac96888d983ead4e75896b78f96777c40d6 (patch)
treec25b1c7e6e1e023d00a7fd9937186df1463e8814 /meta/recipes-devtools
parentda485fc44fb10aede3298dc149d16cbce91d55ae (diff)
downloadopenembedded-core-contrib-caf6dac96888d983ead4e75896b78f96777c40d6.tar.gz
glib-networking/btrfs-tools/dosfstools/parted/bmap-tools/libsoup-2.4: add nativesdk support
In order to make wic tool work in sdk which is out of an existed Yocto build, it needs to port wic tool as a nativesdk recipe. First, make these runtime depends recipes to support nativesdk Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit cb4f7f078e1d3b1afbf93ca4dc5e690f60c59412) Signed-off-by: Steve Sakoman <steve@sakoman.com>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/btrfs-tools/btrfs-tools_5.4.1.bb2
-rw-r--r--meta/recipes-devtools/dosfstools/dosfstools_4.1.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-devtools/btrfs-tools/btrfs-tools_5.4.1.bb b/meta/recipes-devtools/btrfs-tools/btrfs-tools_5.4.1.bb
index cdc971cf5d..4112cf484f 100644
--- a/meta/recipes-devtools/btrfs-tools/btrfs-tools_5.4.1.bb
+++ b/meta/recipes-devtools/btrfs-tools/btrfs-tools_5.4.1.bb
@@ -49,4 +49,4 @@ do_install_append() {
fi
}
-BBCLASSEXTEND = "native"
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta/recipes-devtools/dosfstools/dosfstools_4.1.bb b/meta/recipes-devtools/dosfstools/dosfstools_4.1.bb
index e4ab113391..4bd4aef099 100644
--- a/meta/recipes-devtools/dosfstools/dosfstools_4.1.bb
+++ b/meta/recipes-devtools/dosfstools/dosfstools_4.1.bb
@@ -22,7 +22,7 @@ EXTRA_OECONF = "--without-udev --enable-compat-symlinks"
CFLAGS += "-D_GNU_SOURCE -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
-BBCLASSEXTEND = "native"
+BBCLASSEXTEND = "native nativesdk"
# Add codepage437 to avoid error from `dosfsck -l`
RRECOMMENDS_${PN}_append_libc-glibc = " glibc-gconv-ibm437"