aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorAndrei Gherzan <andrei@gherzan.ro>2012-04-05 23:54:23 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-25 00:02:28 +0100
commitd974ad03c58d7a221ebe3d59c57607928fbbd435 (patch)
tree8d59f9d4edc2f3dc313537b50e61bbb3d4844d28 /meta/recipes-devtools
parent79d0332f21769338a9f904308d8a808486e10fea (diff)
downloadopenembedded-core-contrib-d974ad03c58d7a221ebe3d59c57607928fbbd435.tar.gz
python: Add patch to avoid warning about bsddb module
_bsddb module can be built only with db version between 4.1 and 4.7. Avoid a warning by not adding this module to missing variable. [YOCTO #1937] Signed-off-by: Andrei Gherzan <andrei@gherzan.ro> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/python/python/avoid_warning_about_bsddb.patch23
-rw-r--r--meta/recipes-devtools/python/python_2.7.2.bb3
2 files changed, 25 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python/avoid_warning_about_bsddb.patch b/meta/recipes-devtools/python/python/avoid_warning_about_bsddb.patch
new file mode 100644
index 0000000000..4968744cb6
--- /dev/null
+++ b/meta/recipes-devtools/python/python/avoid_warning_about_bsddb.patch
@@ -0,0 +1,23 @@
+_bsddb module can be built only with db version between 4.1 and 4.7.
+Avoid a warning by not adding this module to missing variable.
+
+Upstream-Status: Inappropriate [distribution]
+
+Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
+
+
+Index: Python-2.7.2/setup.py
+===================================================================
+--- Python-2.7.2.orig/setup.py 2012-04-05 23:16:49.268139840 +0300
++++ Python-2.7.2/setup.py 2012-04-05 23:17:30.912138622 +0300
+@@ -1024,7 +1024,9 @@
+ db_incs = None
+ dblibs = []
+ dblib_dir = None
+- missing.append('_bsddb')
++ # We need db version between 4.1 and 4.7
++ # Avoid this warning
++ #missing.append('_bsddb')
+
+ # The sqlite interface
+ sqlite_setup_debug = False # verbose debug prints from this script?
diff --git a/meta/recipes-devtools/python/python_2.7.2.bb b/meta/recipes-devtools/python/python_2.7.2.bb
index d25b882d95..9c53fc6cde 100644
--- a/meta/recipes-devtools/python/python_2.7.2.bb
+++ b/meta/recipes-devtools/python/python_2.7.2.bb
@@ -1,6 +1,6 @@
require python.inc
DEPENDS = "python-native bzip2 db gdbm openssl readline sqlite3 zlib"
-PR = "${INC_PR}.17"
+PR = "${INC_PR}.18"
DISTRO_SRC_URI ?= "file://sitecustomize.py"
DISTRO_SRC_URI_linuxstdbase = ""
@@ -24,6 +24,7 @@ SRC_URI += "\
file://setuptweaks.patch \
file://check-if-target-is-64b-not-host.patch \
file://search_db_h_in_inc_dirs_and_avoid_warning.patch \
+ file://avoid_warning_about_bsddb.patch \
"
S = "${WORKDIR}/Python-${PV}"