aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-08-15 15:03:30 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-16 09:18:46 +0100
commita0c9d19b46ccefbb90eea5965e11ea21d13242b4 (patch)
tree5a8a780e365fd9d9881e42c6586ac512b5cb42af /meta/recipes-devtools
parentce55e6c6d8b654b5fb21dec8180b471bfd33601a (diff)
downloadopenembedded-core-contrib-a0c9d19b46ccefbb90eea5965e11ea21d13242b4.tar.gz
llvm: Swith to ARM ISA on armv5 and armv4t
When Thumb1 is used as default ISA, there are linker issues, therefore always use ARM ISA Fixes relocation truncated to fit: R_ARM_THM_CALL against symbol `__gnu_thumb1_case_uhi' defined in .text section Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/llvm/llvm_git.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-devtools/llvm/llvm_git.bb b/meta/recipes-devtools/llvm/llvm_git.bb
index 09031f5477..632178fd77 100644
--- a/meta/recipes-devtools/llvm/llvm_git.bb
+++ b/meta/recipes-devtools/llvm/llvm_git.bb
@@ -52,6 +52,9 @@ LLVM_TARGETS ?= "${@get_llvm_target_arch(bb, d)}"
LLVM_TARGETS_prepend_x86 = "AMDGPU;"
LLVM_TARGETS_prepend_x86-64 = "AMDGPU;"
+ARM_INSTRUCTION_SET_armv5 = "arm"
+ARM_INSTRUCTION_SET_armv4t = "arm"
+
EXTRA_OECMAKE += "-DLLVM_ENABLE_ASSERTIONS=OFF \
-DLLVM_ENABLE_EXPENSIVE_CHECKS=OFF \
-DLLVM_ENABLE_PIC=ON \