aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorRandy Witt <randy.e.witt@linux.intel.com>2015-10-22 19:46:11 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-10-24 12:21:03 +0100
commitba3493c434ced719135082607e5f2e1d87559952 (patch)
tree0462daf5c903934a6e4fdf5c489d65d5ec9ed550 /meta/recipes-devtools
parenta1202ed17e11400f08064c9065fdfa996554d4ad (diff)
downloadopenembedded-core-contrib-ba3493c434ced719135082607e5f2e1d87559952.tar.gz
mtools_4.0.18.bb: Use create_wrapper() for mcopy
mcopy uses the IBM850 codepage from gconv. The default install location for gconv will not match the actual install location since it can be pulled from sstate. This patch overrides the default location when running by adding GCONV_PATH to the environment for mcopy. [YOCTO #7629] Signed-off-by: Randy Witt <randy.e.witt@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/mtools/mtools_4.0.18.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-devtools/mtools/mtools_4.0.18.bb b/meta/recipes-devtools/mtools/mtools_4.0.18.bb
index 52decfdf63..24c9d49312 100644
--- a/meta/recipes-devtools/mtools/mtools_4.0.18.bb
+++ b/meta/recipes-devtools/mtools/mtools_4.0.18.bb
@@ -45,3 +45,8 @@ do_install_prepend () {
mkdir -p ${D}/${bindir}
mkdir -p ${D}/${datadir}
}
+
+do_install_append_class-native () {
+ create_wrapper ${D}${bindir}/mcopy \
+ GCONV_PATH=${libdir}/gconv
+}