aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-09-28 01:18:42 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-09-29 15:15:48 +0100
commit3f34288743edef8f50ed16c30df0e1430239ca1b (patch)
treeac4844f35029cc90608723d3d8dbe32e4363119e /meta/recipes-devtools
parenta6616f1a7b8e30428e61b6437f2f48379efc101d (diff)
downloadopenembedded-core-contrib-3f34288743edef8f50ed16c30df0e1430239ca1b.tar.gz
python-async: inherit setuptools
Fixed when bitbake nativesdk-python-async: DEBUG: Executing shell function do_compile Traceback (most recent call last): File "setup.py", line 2, in <module> from setuptools import setup ImportError: No module named setuptools Replace distutils with setuptools will fix the problem. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/python/python-async_0.6.2.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python-async_0.6.2.bb b/meta/recipes-devtools/python/python-async_0.6.2.bb
index 8ed0b0393f..5a17a1a004 100644
--- a/meta/recipes-devtools/python/python-async_0.6.2.bb
+++ b/meta/recipes-devtools/python/python-async_0.6.2.bb
@@ -10,7 +10,7 @@ SRC_URI[sha256sum] = "ac6894d876e45878faae493b0cf61d0e28ec417334448ac0a6ea2229d8
S = "${WORKDIR}/async-${PV}"
-inherit distutils
+inherit setuptools
RDEPENDS_${PN} += "python-threading python-lang"