aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-04-11 20:49:23 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-04-11 21:56:28 +0100
commit1485d7cae88adb3575c6eaa47784fe50820d2740 (patch)
tree7a2cea5610e6de14ab210b7b2d6a9cea0573fae0 /meta/recipes-devtools
parent25bd4e9483a7d2c16a460b4f363e91b5b943bb58 (diff)
downloadopenembedded-core-contrib-1485d7cae88adb3575c6eaa47784fe50820d2740.tar.gz
meta: remove redundant ac_cv_sizeof_off_t assignments
ac_cv_sizeof_off_t was previously in the site cache files, which was breaking large file support and required a workaround in each recipe that actually wanted to use large files. Now that the entry has been removed from the site cache, we can remove the workarounds. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/python/python.inc2
-rw-r--r--meta/recipes-devtools/python/python_2.7.11.bb3
2 files changed, 1 insertions, 4 deletions
diff --git a/meta/recipes-devtools/python/python.inc b/meta/recipes-devtools/python/python.inc
index 52250d27bb..f4818c6a87 100644
--- a/meta/recipes-devtools/python/python.inc
+++ b/meta/recipes-devtools/python/python.inc
@@ -20,8 +20,6 @@ PYTHON_MAJMIN = "2.7"
inherit autotools
-PYTHONLSBOPTS_linuxstdbase = "ac_cv_sizeof_off_t=8"
-
EXTRA_OECONF = "\
--with-threads \
--with-pymalloc \
diff --git a/meta/recipes-devtools/python/python_2.7.11.bb b/meta/recipes-devtools/python/python_2.7.11.bb
index 0c00d6e4e4..606f153623 100644
--- a/meta/recipes-devtools/python/python_2.7.11.bb
+++ b/meta/recipes-devtools/python/python_2.7.11.bb
@@ -35,8 +35,7 @@ inherit autotools multilib_header python-dir pythonnative
CONFIGUREOPTS += " --with-system-ffi "
-# The following is a hack until we drop ac_cv_sizeof_off_t from site files
-EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'largefile', 'ac_cv_sizeof_off_t=8', '', d)} ac_cv_file__dev_ptmx=yes ac_cv_file__dev_ptc=no"
+EXTRA_OECONF += "ac_cv_file__dev_ptmx=yes ac_cv_file__dev_ptc=no"
do_configure_append() {
rm -f ${S}/Makefile.orig