summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2019-08-30 14:49:54 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-09-01 22:33:07 +0100
commit8099ad5a212bea506aac7de9a5d6f2176115e894 (patch)
tree8eaa70cebca0f838e8c36f083d43a8110b012cdc /meta/recipes-devtools
parent98da689bce85313de858fc4682e58d3091bdf749 (diff)
downloadopenembedded-core-contrib-8099ad5a212bea506aac7de9a5d6f2176115e894.tar.gz
llvm: use python 3 during builds
(From OE-Core rev: 13f9182e7235843290809027b4456ad2fe5e4c40) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/llvm/llvm_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/llvm/llvm_git.bb b/meta/recipes-devtools/llvm/llvm_git.bb
index 35ad3ced37..08b19a33e3 100644
--- a/meta/recipes-devtools/llvm/llvm_git.bb
+++ b/meta/recipes-devtools/llvm/llvm_git.bb
@@ -71,7 +71,7 @@ EXTRA_OECMAKE += "-DLLVM_ENABLE_ASSERTIONS=OFF \
-DLLVM_OPTIMIZED_TABLEGEN=ON \
-DLLVM_TARGETS_TO_BUILD='${LLVM_TARGETS}' \
-DLLVM_TEMPORARILY_ALLOW_OLD_TOOLCHAIN=ON \
- -DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python2 \
+ -DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3 \
-G Ninja"
EXTRA_OECMAKE_append_class-target = "\