aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2017-04-27 17:28:12 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-05-23 17:43:58 +0100
commit3469c729a14bbf38bd2e9d7456c0651d8f313546 (patch)
tree1165c6b0e5263a691ab2c3d884738762d5343198 /meta/recipes-devtools
parent19e51f05011e827a34890e0c098f3bfa66559e1a (diff)
downloadopenembedded-core-contrib-3469c729a14bbf38bd2e9d7456c0651d8f313546.tar.gz
kconfig-frontends: update to 4.10.0.1
Add a couple of patches: - move python script to use Python 3 - fix .pc file installation path Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/kconfig-frontends/files/0001-Fix-installation-of-.pc-files.patch29
-rw-r--r--meta/recipes-devtools/kconfig-frontends/files/0001-Switch-utils-kconfig-diff-to-use-Python-3.patch26
-rw-r--r--meta/recipes-devtools/kconfig-frontends/kconfig-frontends_4.10.0.1.bb (renamed from meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.12.0.0.bb)8
3 files changed, 60 insertions, 3 deletions
diff --git a/meta/recipes-devtools/kconfig-frontends/files/0001-Fix-installation-of-.pc-files.patch b/meta/recipes-devtools/kconfig-frontends/files/0001-Fix-installation-of-.pc-files.patch
new file mode 100644
index 0000000000..e9195a0afc
--- /dev/null
+++ b/meta/recipes-devtools/kconfig-frontends/files/0001-Fix-installation-of-.pc-files.patch
@@ -0,0 +1,29 @@
+From 80c16b1f39402e8ce33600e5f297920a6d603090 Mon Sep 17 00:00:00 2001
+From: Alexander Kanavin <alex.kanavin@gmail.com>
+Date: Thu, 27 Apr 2017 16:57:06 +0300
+Subject: [PATCH] Fix installation of .pc files
+
+They go to prefix/pkgconfig/, not prefix/pkg-config.
+
+Upstream-Status: Pending
+Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
+---
+ Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 058690a..f9e9b7b 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -107,7 +107,7 @@ EXTRA_DIST += \
+ libs/parser/yconf.y.patch
+
+ # libs/parser/kconfig-parser.pc generated by AC_CONFIG_FILES in configure.ac
+-pkgconfigdir = $(libdir)/pkg-config
++pkgconfigdir = $(libdir)/pkgconfig
+ pkgconfig_DATA = libs/parser/kconfig-parser.pc
+ DISTCLEANFILES += libs/parser/kconfig-parser.pc
+ EXTRA_DIST += libs/parser/kconfig-parser.pc.in
+--
+2.11.0
+
diff --git a/meta/recipes-devtools/kconfig-frontends/files/0001-Switch-utils-kconfig-diff-to-use-Python-3.patch b/meta/recipes-devtools/kconfig-frontends/files/0001-Switch-utils-kconfig-diff-to-use-Python-3.patch
new file mode 100644
index 0000000000..b8f8904816
--- /dev/null
+++ b/meta/recipes-devtools/kconfig-frontends/files/0001-Switch-utils-kconfig-diff-to-use-Python-3.patch
@@ -0,0 +1,26 @@
+From 3b9b0f82c33f793a14d44bf06b6c8136bc3fc4bf Mon Sep 17 00:00:00 2001
+From: Alexander Kanavin <alex.kanavin@gmail.com>
+Date: Thu, 27 Apr 2017 16:48:42 +0300
+Subject: [PATCH] Switch utils/kconfig-diff to use Python 3
+
+The script supports it, but continues to refer to 2.x in shebang.
+
+Upstream-Status: Pending
+Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
+---
+ utils/kconfig-diff | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/utils/kconfig-diff b/utils/kconfig-diff
+index 0db267d..19189f3 100755
+--- a/utils/kconfig-diff
++++ b/utils/kconfig-diff
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python
++#!/usr/bin/env python3
+ #
+ # diffconfig - a tool to compare .config files.
+ #
+--
+2.11.0
+
diff --git a/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.12.0.0.bb b/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_4.10.0.1.bb
index 4ca0e4da3a..be90d6b880 100644
--- a/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.12.0.0.bb
+++ b/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_4.10.0.1.bb
@@ -12,10 +12,12 @@ LICENSE = "GPL-2.0"
LIC_FILES_CHKSUM = "file://COPYING;md5=9b8cf60ff39767ff04b671fca8302408"
SECTION = "devel"
DEPENDS += "ncurses flex bison gperf-native"
-RDEPENDS_${PN} += "python bash"
-SRC_URI = "git://ymorin.is-a-geek.org/kconfig-frontends"
+RDEPENDS_${PN} += "python3 bash"
+SRC_URI = "git://ymorin.is-a-geek.org/kconfig-frontends;branch=4.10.x \
+ file://0001-Fix-installation-of-.pc-files.patch \
+ file://0001-Switch-utils-kconfig-diff-to-use-Python-3.patch"
-SRCREV = "75d35b172fc0f7b6620dd659af41f2ce04edc4e6"
+SRCREV = "f8ffe5e1c6f183cb7d5d515aa9381b7557de654e"
S = "${WORKDIR}/git"