summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2022-01-21 14:47:07 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-01-26 06:25:33 +0000
commit1dc5cdf683133d210658eba9a619b737ec95cfe3 (patch)
treeccd631e475e0028196578467e56ffd665e2f8de4 /meta/recipes-devtools
parent739b3af0bf1422cdabd13ccac8fbcc60b37d2fa4 (diff)
downloadopenembedded-core-contrib-1dc5cdf683133d210658eba9a619b737ec95cfe3.tar.gz
ruby: do not parallel install
ruby's makefiles are rebuilding several items on every invocation, even if nothing changed, all of which are factored into libruby.so and cause it to be relinked as well. This does not seem to affect plain make invocation, but does cause races in make install: https://bugzilla.yoctoproject.org/show_bug.cgi?id=14695 Rather than figure out how to use make properly and convince upstream of it, let's just do serial installs and file a bug: https://bugs.ruby-lang.org/issues/18506 Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/ruby/ruby_3.1.0.bb4
1 files changed, 1 insertions, 3 deletions
diff --git a/meta/recipes-devtools/ruby/ruby_3.1.0.bb b/meta/recipes-devtools/ruby/ruby_3.1.0.bb
index 7183c93d45..e250164d2c 100644
--- a/meta/recipes-devtools/ruby/ruby_3.1.0.bb
+++ b/meta/recipes-devtools/ruby/ruby_3.1.0.bb
@@ -48,9 +48,7 @@ EXTRA_OECONF:append:libc-musl:riscv32 = "\
--with-coroutine=copy \
"
-do_install() {
- oe_runmake 'DESTDIR=${D}' install
-}
+PARALLEL_MAKEINST = ""
do_install:append:class-target () {
# Find out rbconfig.rb from .installed.list