aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorMaxin B. John <maxin.john@intel.com>2018-08-16 13:41:30 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-08-19 16:33:41 +0100
commitdfbbff39cfd413510abbd60930232a9c6b35d765 (patch)
treef2c9e570e62bbc059f66e3632efa11bed877a05f /meta/recipes-devtools
parent13cf502fce8956f95fdc8ac0c7a37d741223bcc9 (diff)
downloadopenembedded-core-contrib-dfbbff39cfd413510abbd60930232a9c6b35d765.tar.gz
vala: refresh patch
Refresh the following patch: "disable-graphviz.patch" to fix this warning: Some of the context lines in patches were ignored. This can lead to incorrectly applied patches. The context lines in the patches can be updated with devtool: devtool modify <recipe> devtool finish --force-patch-refresh <recipe> <layer_path> Then the updated patches and the source tree (in devtool's workspace) should be reviewed to make sure the patches apply in the correct place and don't introduce duplicate lines (which can, and does happen when some of the context is ignored). Further information: http://lists.openembedded.org/pipermail/openembedded-core/2018-March/148675.html https://bugzilla.yoctoproject.org/show_bug.cgi?id=10450 Details: checking file configure.ac checking file libvaladoc/Makefile.am checking file libvaladoc/html/basicdoclet.vala checking file libvaladoc/html/htmlmarkupwriter.vala Hunk #1 succeeded at 51 with fuzz 1 (offset 8 lines). Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/vala/vala/disable-graphviz.patch13
1 files changed, 7 insertions, 6 deletions
diff --git a/meta/recipes-devtools/vala/vala/disable-graphviz.patch b/meta/recipes-devtools/vala/vala/disable-graphviz.patch
index 8fb94dc149..e7e38c768e 100644
--- a/meta/recipes-devtools/vala/vala/disable-graphviz.patch
+++ b/meta/recipes-devtools/vala/vala/disable-graphviz.patch
@@ -1,7 +1,8 @@
-From 500f4220f79c660a70a1ffc0d5b762d70088af5e Mon Sep 17 00:00:00 2001
+From 5ae347907b8c65983365a6325ac990fcde28d508 Mon Sep 17 00:00:00 2001
From: Rico Tzschichholz <ricotz@ubuntu.com>
Date: Wed, 6 Sep 2017 18:52:55 +0200
Subject: [PATCH] libvaladoc: Allow disabling the graphviz dependency of
+
valadoc
https://bugzilla.gnome.org/show_bug.cgi?id=787375
@@ -16,7 +17,7 @@ Upstream-Status: Submitted [bugzilla link above]
4 files changed, 63 insertions(+), 34 deletions(-)
diff --git a/configure.ac b/configure.ac
-index 662180b..82d7015 100644
+index 694ffd2..9150620 100644
--- a/configure.ac
+++ b/configure.ac
@@ -112,34 +112,38 @@ PKG_CHECK_MODULES(GMODULE, gmodule-2.0 >= $GLIB_REQUIRED)
@@ -159,7 +160,7 @@ index 384292f..cce50d8 100644
EXTRA_DIST = \
$(libvaladoc_la_VALASOURCES) \
diff --git a/libvaladoc/html/basicdoclet.vala b/libvaladoc/html/basicdoclet.vala
-index cc9ea4e..432c381 100644
+index 37c731c..e0326ef 100644
--- a/libvaladoc/html/basicdoclet.vala
+++ b/libvaladoc/html/basicdoclet.vala
@@ -46,7 +46,11 @@ public abstract class Valadoc.Html.BasicDoclet : Api.Visitor, Doclet {
@@ -201,11 +202,11 @@ index cc9ea4e..432c381 100644
public void write_namespace_content (Namespace node, Api.Node? parent) {
diff --git a/libvaladoc/html/htmlmarkupwriter.vala b/libvaladoc/html/htmlmarkupwriter.vala
-index 15ed9ef..fe0d705 100644
+index dcc4dad..cf9c860 100644
--- a/libvaladoc/html/htmlmarkupwriter.vala
+++ b/libvaladoc/html/htmlmarkupwriter.vala
-@@ -43,12 +43,16 @@ public class Valadoc.Html.MarkupWriter : Valadoc.MarkupWriter {
- }, xml_declaration);
+@@ -51,12 +51,16 @@ public class Valadoc.Html.MarkupWriter : Valadoc.MarkupWriter {
+ }
}
+#if HAVE_GRAPHVIZ