summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorTomasz Dziendzielski <tomasz.dziendzielski@gmail.com>2021-01-24 10:55:46 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-01-27 10:16:13 +0000
commit217a8974765693192cbead51ebd9845a383ef7cc (patch)
tree56086643eecb217ec3534abab60e5503aa20f4ba /meta/recipes-devtools
parent044c90d152bfd1b2a23272df39327ba4cd862dff (diff)
downloadopenembedded-core-contrib-217a8974765693192cbead51ebd9845a383ef7cc.tar.gz
meta: Fix native inheritance order in recipes
Classes native/nativesdk should be inherited last to prevent unexpected behaviour. See [YOCTO #5729] for details. Signed-off-by: Tomasz Dziendzielski <tomasz.dziendzielski@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/meson/nativesdk-meson_0.56.2.bb2
-rw-r--r--meta/recipes-devtools/qemu/qemu-native.inc4
2 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-devtools/meson/nativesdk-meson_0.56.2.bb b/meta/recipes-devtools/meson/nativesdk-meson_0.56.2.bb
index 7fdc4c86d9..8778cab124 100644
--- a/meta/recipes-devtools/meson/nativesdk-meson_0.56.2.bb
+++ b/meta/recipes-devtools/meson/nativesdk-meson_0.56.2.bb
@@ -1,7 +1,7 @@
include meson.inc
-inherit nativesdk
inherit siteinfo
+inherit nativesdk
SRC_URI += "file://meson-setup.py \
file://meson-wrapper"
diff --git a/meta/recipes-devtools/qemu/qemu-native.inc b/meta/recipes-devtools/qemu/qemu-native.inc
index aa5c9b9a72..54e49d8bc6 100644
--- a/meta/recipes-devtools/qemu/qemu-native.inc
+++ b/meta/recipes-devtools/qemu/qemu-native.inc
@@ -1,7 +1,7 @@
-inherit native
-
require qemu.inc
+inherit native
+
EXTRA_OEMAKE_append = " LD='${LD}' AR='${AR}' OBJCOPY='${OBJCOPY}' LDFLAGS='${LDFLAGS}'"
LDFLAGS_append = " -fuse-ld=bfd"