aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2019-03-08 06:37:26 -0800
committerArmin Kuster <akuster808@gmail.com>2019-04-13 12:30:32 -0700
commite7721ee7e7942570ebab793f5870d7a021154a92 (patch)
treed35b70347e7b7d1182142298f4b3cbb4cbe8a2e5 /meta/recipes-devtools
parentaa5c0d159c5016c6517f42a0a1738188b5646517 (diff)
downloadopenembedded-core-contrib-e7721ee7e7942570ebab793f5870d7a021154a92.tar.gz
python: time.tzset missing
import time time.tzset() Traceback (most recent call last): File "<stdin>", line 1, in <module> AttributeError: module 'time' has no attribute 'tzset' enable tzset in both python versions Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> [Fix up for Thud context ie python3_3.5.6] Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/python/python3_3.5.6.bb1
-rw-r--r--meta/recipes-devtools/python/python_2.7.15.bb2
2 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python3_3.5.6.bb b/meta/recipes-devtools/python/python3_3.5.6.bb
index 2cb65045aa..6aa6df658c 100644
--- a/meta/recipes-devtools/python/python3_3.5.6.bb
+++ b/meta/recipes-devtools/python/python3_3.5.6.bb
@@ -61,6 +61,7 @@ CACHED_CONFIGUREVARS = "ac_cv_have_chflags=no \
ac_cv_buggy_getaddrinfo=no \
ac_cv_file__dev_ptmx=yes \
ac_cv_file__dev_ptc=no \
+ ac_cv_working_tzset=yes \
"
TARGET_CC_ARCH += "-DNDEBUG -fno-inline"
diff --git a/meta/recipes-devtools/python/python_2.7.15.bb b/meta/recipes-devtools/python/python_2.7.15.bb
index c22c762d99..3f361ae7c4 100644
--- a/meta/recipes-devtools/python/python_2.7.15.bb
+++ b/meta/recipes-devtools/python/python_2.7.15.bb
@@ -41,7 +41,7 @@ inherit autotools multilib_header python-dir pythonnative ptest
CONFIGUREOPTS += " --with-system-ffi "
-EXTRA_OECONF += "ac_cv_file__dev_ptmx=yes ac_cv_file__dev_ptc=no"
+EXTRA_OECONF += "ac_cv_file__dev_ptmx=yes ac_cv_file__dev_ptc=no ac_cv_working_tzset=yes"
PACKAGECONFIG ??= "bdb"
PACKAGECONFIG[bdb] = ",,db"