aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2019-04-11 15:02:32 +0800
committerArmin Kuster <akuster808@gmail.com>2019-04-14 07:23:46 -0700
commit3a0272bab546a4b47feab117713e32873419bbe7 (patch)
treea32d30b4bbed87c291ad7200034e5cc90660dfe4 /meta/recipes-devtools
parenta9cc1b3f9a684c14f02b06226693b023adc3e609 (diff)
downloadopenembedded-core-contrib-3a0272bab546a4b47feab117713e32873419bbe7.tar.gz
ruby: make ext module fiddle can compile success
ext module fiddle depend on libffi, in ruby source tree, there is in internal libffi in case target platfrom don't install libffi, but autotools.bbclass delete configure under libffi and not run autoreconf to regenerate one.so we met this error: ruby-2.5.3/ext/fiddle/libffi-3.2.1/configure: No such file or directory the fix is add depend and extra_oeconf to use libffi in the system Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/ruby/ruby.inc2
-rw-r--r--meta/recipes-devtools/ruby/ruby_2.5.3.bb1
2 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-devtools/ruby/ruby.inc b/meta/recipes-devtools/ruby/ruby.inc
index eaf5d13ac2..28e21fee9c 100644
--- a/meta/recipes-devtools/ruby/ruby.inc
+++ b/meta/recipes-devtools/ruby/ruby.inc
@@ -14,7 +14,7 @@ LIC_FILES_CHKSUM = "\
file://LEGAL;md5=23a79bb4c1a40f6cc9bcb6f4e7c39799 \
"
-DEPENDS = "ruby-native zlib openssl tcl libyaml gdbm readline"
+DEPENDS = "ruby-native zlib openssl tcl libyaml gdbm readline libffi"
DEPENDS_class-native = "openssl-native libyaml-native readline-native"
SHRT_VER = "${@oe.utils.trim_version("${PV}", 2)}"
diff --git a/meta/recipes-devtools/ruby/ruby_2.5.3.bb b/meta/recipes-devtools/ruby/ruby_2.5.3.bb
index 3fb427e90e..173b44b377 100644
--- a/meta/recipes-devtools/ruby/ruby_2.5.3.bb
+++ b/meta/recipes-devtools/ruby/ruby_2.5.3.bb
@@ -28,6 +28,7 @@ EXTRA_OECONF = "\
--disable-dtrace \
--enable-shared \
--enable-load-relative \
+ --with-pkg-config=pkg-config \
"
do_install() {