aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorAndré Draszik <andre.draszik@jci.com>2019-01-13 11:16:01 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-01-28 16:56:33 +0000
commit2da88ecbbf118bb7440f48184d4b39c273ab57e9 (patch)
tree4274e4154745dcd885509395bf892f902492bdfe /meta/recipes-devtools
parent1bd93c625fa64cdddc260fdd164cc0d2c5272ee0 (diff)
downloadopenembedded-core-contrib-2da88ecbbf118bb7440f48184d4b39c273ab57e9.tar.gz
meta: remove True option to getVar calls (again)
A couple have still been missed in the past despite multiple attempts at doing so (or simply have re-appeared?). Search & replace made using the following command: sed -e 's|\(d\.getVar \?\)( \?\([^,()]*\), \?True)|\1(\2)|g' \ -i $(git grep -E 'getVar ?\( ?([^,()]*), ?True\)' \ | cut -d':' -f1 \ | sort -u) (From OE-Core rev: 9f551d588693328e4d99d33be94f26684eafcaba) Signed-off-by: André Draszik <andre.draszik@jci.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/python/python-native_2.7.15.bb2
-rw-r--r--meta/recipes-devtools/python/python3-native_3.5.6.bb2
-rw-r--r--meta/recipes-devtools/rpm/rpm_4.14.2.bb6
3 files changed, 5 insertions, 5 deletions
diff --git a/meta/recipes-devtools/python/python-native_2.7.15.bb b/meta/recipes-devtools/python/python-native_2.7.15.bb
index de35104c60..9d0fe3b84f 100644
--- a/meta/recipes-devtools/python/python-native_2.7.15.bb
+++ b/meta/recipes-devtools/python/python-native_2.7.15.bb
@@ -67,7 +67,7 @@ python(){
# Read JSON manifest
import json
- pythondir = d.getVar('THISDIR',True)
+ pythondir = d.getVar('THISDIR')
with open(pythondir+'/python/python2-manifest.json') as manifest_file:
manifest_str = manifest_file.read()
json_start = manifest_str.find('# EOC') + 6
diff --git a/meta/recipes-devtools/python/python3-native_3.5.6.bb b/meta/recipes-devtools/python/python3-native_3.5.6.bb
index 56236da07f..c7bc4f3b0a 100644
--- a/meta/recipes-devtools/python/python3-native_3.5.6.bb
+++ b/meta/recipes-devtools/python/python3-native_3.5.6.bb
@@ -81,7 +81,7 @@ python(){
# Read JSON manifest
import json
- pythondir = d.getVar('THISDIR',True)
+ pythondir = d.getVar('THISDIR')
with open(pythondir+'/python3/python3-manifest.json') as manifest_file:
python_manifest=json.load(manifest_file)
diff --git a/meta/recipes-devtools/rpm/rpm_4.14.2.bb b/meta/recipes-devtools/rpm/rpm_4.14.2.bb
index 200fe4da26..75ef3f4d03 100644
--- a/meta/recipes-devtools/rpm/rpm_4.14.2.bb
+++ b/meta/recipes-devtools/rpm/rpm_4.14.2.bb
@@ -104,9 +104,9 @@ do_install_append_class-native() {
do_install_append_class-nativesdk() {
for tool in ${WRAPPER_TOOLS}; do
create_wrapper ${D}$tool \
- RPM_CONFIGDIR='`dirname $''realpath`'/${@os.path.relpath(d.getVar('libdir', True), d.getVar('bindir', True))}/rpm \
- RPM_ETCCONFIGDIR='$'{RPM_ETCCONFIGDIR-'`dirname $''realpath`'/${@os.path.relpath(d.getVar('sysconfdir', True), d.getVar('bindir', True))}/..} \
- MAGIC='`dirname $''realpath`'/${@os.path.relpath(d.getVar('datadir', True), d.getVar('bindir', True))}/misc/magic.mgc \
+ RPM_CONFIGDIR='`dirname $''realpath`'/${@os.path.relpath(d.getVar('libdir'), d.getVar('bindir'))}/rpm \
+ RPM_ETCCONFIGDIR='$'{RPM_ETCCONFIGDIR-'`dirname $''realpath`'/${@os.path.relpath(d.getVar('sysconfdir'), d.getVar('bindir'))}/..} \
+ MAGIC='`dirname $''realpath`'/${@os.path.relpath(d.getVar('datadir'), d.getVar('bindir'))}/misc/magic.mgc \
RPM_NO_CHROOT_FOR_SCRIPTS=1
done