summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2019-02-22 10:15:44 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-02-25 10:42:56 +0000
commit6257fcd86e63fe533aeaadbc65a54213b4885c16 (patch)
tree90183acdbd7da09762f5384f52fde5ed3e399934 /meta/recipes-devtools
parent57f32836060bba0eaa6b36f53146dd6fd07b77ed (diff)
downloadopenembedded-core-contrib-6257fcd86e63fe533aeaadbc65a54213b4885c16.tar.gz
perl: fix incorrect symbolic link for libperl.so
The perl-cross uses PERL_API_VERSION but not PERL_VERSION to define libperl soname: libperl.so.$PERL_API_REVISION.$PERL_API_VERSION.$PERL_API_SUBVERSION. For perl stable releases, the PERL_API_SUBVERSION is always 0. Specify the so version for libperl to make sure the libperl.so can be linked to the correct library. Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/perl-sanity/perl_5.28.1.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-devtools/perl-sanity/perl_5.28.1.bb b/meta/recipes-devtools/perl-sanity/perl_5.28.1.bb
index 71653feb53..1cc5480d68 100644
--- a/meta/recipes-devtools/perl-sanity/perl_5.28.1.bb
+++ b/meta/recipes-devtools/perl-sanity/perl_5.28.1.bb
@@ -34,6 +34,8 @@ inherit upstream-version-is-even
DEPENDS += "db gdbm zlib virtual/crypt"
+PERL_LIB_VER = "${@'.'.join(d.getVar('PV').split('.')[0:2])}.0"
+
do_unpack_append() {
bb.build.exec_func('do_copy_perlcross', d)
}
@@ -104,7 +106,7 @@ do_install() {
# Fix up shared library
rm ${D}/${libdir}/perl5/${PV}/${TARGET_ARCH}-linux/CORE/libperl.so
- ln -sf ../../../../libperl.so.${PV} ${D}/${libdir}/perl5/${PV}/${TARGET_ARCH}-linux/CORE/libperl.so
+ ln -sf ../../../../libperl.so.${PERL_LIB_VER} ${D}/${libdir}/perl5/${PV}/${TARGET_ARCH}-linux/CORE/libperl.so
}
do_install_append_class-target() {