summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2019-02-20 21:10:24 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-02-25 11:44:52 +0000
commit18f565f3ca18c281b4a99721fcfcbcc5405d6346 (patch)
tree428ee5171ace8132c6196d2c7d6cb6987ed9f96c /meta/recipes-devtools
parentce0e5719c9b10121c32be67237b88b0289499f2f (diff)
downloadopenembedded-core-contrib-18f565f3ca18c281b4a99721fcfcbcc5405d6346.tar.gz
llvm: switch to the official git repository
Until now an unoffcial mirror was used, which may or may not be maintained in the longer run, as the need for it has gone. Also, the official mirror has version tags which allows us to track upstream development in an automated manner. ${S} has changed as upstream decided to use a monorepo for all of the llvm-related projects. Further info: https://www.phoronix.com/scan.php?page=news_item&px=LLVM-GitHub-Mono-Repo https://llvm.org/docs/GettingStarted.html#checkout-llvm-from-git Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/llvm/llvm_git.bb14
1 files changed, 9 insertions, 5 deletions
diff --git a/meta/recipes-devtools/llvm/llvm_git.bb b/meta/recipes-devtools/llvm/llvm_git.bb
index eca78af09e..c68512cc63 100644
--- a/meta/recipes-devtools/llvm/llvm_git.bb
+++ b/meta/recipes-devtools/llvm/llvm_git.bb
@@ -19,20 +19,24 @@ PROVIDES += "llvm${PV}"
LLVM_RELEASE = "${PV}"
LLVM_DIR = "llvm${LLVM_RELEASE}"
-SRCREV = "e5cc6808dc0d5b773479bf36c51d59d0d3174733"
-BRANCH = "release_${MAJOR_VERSION}${MINOR_VERSION}"
+# SRCREV is set to the revision of 8.0.0-rc2 tag, while latest release
+# tag is 7.0.1 as of Feb 18 2019, hence the need for UPSTREAM_CHECK_UNKNOWN
+# Remove the UPSTREAM_VERSION_UNKNOWN line once 8.0.0 final is tagged
+UPSTREAM_VERSION_UNKNOWN = "1"
+SRCREV = "98ebe7460199b9cd79eb562b5e8705ad28f5513f"
+
+BRANCH = "release/${MAJOR_VERSION}.x"
MAJOR_VERSION = "8"
MINOR_VERSION = "0"
PATCH_VERSION = "0"
SOLIBVER = "1"
PV = "${MAJOR_VERSION}.${MINOR_VERSION}"
-SRC_URI = "git://github.com/llvm-mirror/llvm.git;branch=${BRANCH} \
+SRC_URI = "git://github.com/llvm/llvm-project.git;branch=${BRANCH} \
file://0001-llvm-TargetLibraryInfo-Undefine-libc-functions-if-th.patch \
file://0002-llvm-allow-env-override-of-exe-path.patch \
"
-UPSTREAM_CHECK_COMMITS = "1"
-S = "${WORKDIR}/git"
+S = "${WORKDIR}/git/llvm"
LLVM_INSTALL_DIR = "${WORKDIR}/llvm-install"