summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-05-08 08:16:03 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-05-13 15:42:24 +0100
commit800e6576e4f3af10846af13c2f217f986c1afdb4 (patch)
tree3d06195701d2f508ff2b6094b4f79c0c09c68a13 /meta/recipes-devtools
parent12dfa6889a1c322d0e20fd9b7638dcb861e032f2 (diff)
downloadopenembedded-core-contrib-800e6576e4f3af10846af13c2f217f986c1afdb4.tar.gz
llvm: Switch to using release tarballs
git checkouts are in excess of 3G, which is not ideal for everyone to download/clone, instead switch to fetching release tarball which is ~126M as of 18.1.5 release Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/llvm/llvm_18.1.5.bb (renamed from meta/recipes-devtools/llvm/llvm_git.bb)13
1 files changed, 6 insertions, 7 deletions
diff --git a/meta/recipes-devtools/llvm/llvm_git.bb b/meta/recipes-devtools/llvm/llvm_18.1.5.bb
index 6413b041a8..9c80b46b60 100644
--- a/meta/recipes-devtools/llvm/llvm_git.bb
+++ b/meta/recipes-devtools/llvm/llvm_18.1.5.bb
@@ -13,27 +13,26 @@ DEPENDS = "libffi libxml2 zlib zstd libedit ninja-native llvm-native"
RDEPENDS:${PN}:append:class-target = " ncurses-terminfo"
inherit cmake pkgconfig
-
# could be 'rcX' or 'git' or empty ( for release )
VER_SUFFIX = ""
-PV = "18.1.5${VER_SUFFIX}"
+PV .= "${VER_SUFFIX}"
MAJOR_VERSION = "${@oe.utils.trim_version("${PV}", 1)}"
LLVM_RELEASE = "${PV}"
-BRANCH = "release/${MAJOR_VERSION}.x"
-SRCREV = "617a15a9eac96088ae5e9134248d8236e34b91b1"
-SRC_URI = "git://github.com/llvm/llvm-project.git;branch=${BRANCH};protocol=https \
+SRC_URI = "https://github.com/llvm/llvm-project/releases/download/llvmorg-${PV}/llvm-project-${PV}.src.tar.xz \
file://0007-llvm-allow-env-override-of-exe-path.patch;striplevel=2 \
file://0001-AsmMatcherEmitter-sort-ClassInfo-lists-by-name-as-we.patch;striplevel=2 \
file://llvm-config \
"
+SRC_URI[sha256sum] = "3591a52761a7d390ede51af01ea73abfecc4b1d16445f9d019b67a57edd7de56"
-UPSTREAM_CHECK_GITTAGREGEX = "llvmorg-(?P<pver>\d+(\.\d+)+)"
+UPSTREAM_CHECK_URI = "https://github.com/llvm/llvm-project"
+UPSTREAM_CHECK_REGEX = "llvmorg-(?P<pver>\d+(\.\d+)+)"
-S = "${WORKDIR}/git/llvm"
+S = "${WORKDIR}/llvm-project-${PV}.src/llvm"
LLVM_INSTALL_DIR = "${WORKDIR}/llvm-install"