summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorDan Callaghan <dan.callaghan@opengear.com>2019-10-16 08:44:56 +1000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-10-31 16:07:11 +0000
commita898b13763a145f15dfd8ada033ae9f0d60e4185 (patch)
tree5ba04dde4dd7bda81cba951ab48144018d4a4541 /meta/recipes-devtools
parentcb5bb2b9635ebf709f1eb0b154f28419d548ad70 (diff)
downloadopenembedded-core-contrib-a898b13763a145f15dfd8ada033ae9f0d60e4185.tar.gz
elfutils: add PACKAGECONFIG for compression algorithms
Elfutils has optional support for bzip2 and xz (lzma). It uses this for decompressing embedded ELF sections like the .gnu_debugdata section for "mini debuginfo": https://sourceware.org/gdb/onlinedocs/gdb/MiniDebugInfo.html Previously this support was unconditionally disabled but the reasons for disabling them seem to no longer apply. Both the target and native variants of elfutils can build successfully against both bzip2 and xz. (From OE-Core rev: 37f4b2311eab6736ee92fc6ac39ddcba6d56a38e) Signed-off-by: Dan Callaghan <dan.callaghan@opengear.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/elfutils/elfutils_0.177.bb13
1 files changed, 10 insertions, 3 deletions
diff --git a/meta/recipes-devtools/elfutils/elfutils_0.177.bb b/meta/recipes-devtools/elfutils/elfutils_0.177.bb
index 818794266c..da0e958762 100644
--- a/meta/recipes-devtools/elfutils/elfutils_0.177.bb
+++ b/meta/recipes-devtools/elfutils/elfutils_0.177.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "https://sourceware.org/elfutils"
SECTION = "base"
LICENSE = "GPLv2 & LGPLv3+ & GPLv3+"
LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
-DEPENDS = "bzip2 zlib virtual/libintl"
+DEPENDS = "zlib virtual/libintl"
DEPENDS_append_libc-musl = " argp-standalone fts musl-obstack "
# The Debian patches below are from:
# http://ftp.de.debian.org/debian/pool/main/e/elfutils/elfutils_0.176-1.debian.tar.xz
@@ -46,8 +46,15 @@ SRC_URI[sha256sum] = "fa489deccbcae7d8c920f60d85906124c1989c591196d90e0fd668e3dc
inherit autotools gettext ptest
-EXTRA_OECONF = "--program-prefix=eu- --without-lzma"
-EXTRA_OECONF_append_class-native = " --without-bzlib"
+EXTRA_OECONF = "--program-prefix=eu-"
+
+DEPENDS_BZIP2 = "bzip2-replacement-native"
+DEPENDS_BZIP2_class-target = "bzip2"
+
+PACKAGECONFIG ??= "bzip2"
+PACKAGECONFIG[bzip2] = "--with-bzlib,--without-bzlib,${DEPENDS_BZIP2}"
+PACKAGECONFIG[xz] = "--with-lzma,--without-lzma,xz"
+
RDEPENDS_${PN}-ptest += "libasm libelf bash make coreutils ${PN}-binutils"
EXTRA_OECONF_append_class-target += "--disable-tests-rpath"