aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2015-02-20 16:39:40 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-02-21 22:04:24 +0000
commitbb8a7b906204b25f07fe568883c2d605593c323c (patch)
treef05698c875b017983479b464613095674eaae98d /meta/recipes-devtools
parentfd8158134f3d7a7c795c818cc50eb2858a6cae06 (diff)
downloadopenembedded-core-contrib-bb8a7b906204b25f07fe568883c2d605593c323c.tar.gz
opkg: fix systemd unit installation
SYSTEMD_SERVICE doesn't need to be set conditionally, and units should be installed if the systemd DISTRO_FEATURE is enabled, not if sysvinit isn't enabled. Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/opkg/opkg_0.2.4.bb8
1 files changed, 2 insertions, 6 deletions
diff --git a/meta/recipes-devtools/opkg/opkg_0.2.4.bb b/meta/recipes-devtools/opkg/opkg_0.2.4.bb
index 7b49d5efe6..4051b7221e 100644
--- a/meta/recipes-devtools/opkg/opkg_0.2.4.bb
+++ b/meta/recipes-devtools/opkg/opkg_0.2.4.bb
@@ -26,11 +26,7 @@ SRC_URI[sha256sum] = "0f40c7e457d81edf9aedc07c778f4697111ab163a38ef95999faece015
inherit autotools pkgconfig systemd
-python () {
- if not bb.utils.contains('DISTRO_FEATURES', 'sysvinit', True, False, d):
- pn = d.getVar('PN', True)
- d.setVar('SYSTEMD_SERVICE_%s' % (pn), 'opkg-configure.service')
-}
+SYSTEMD_SERVICE_${PN} = "opkg-configure.service"
target_localstatedir := "${localstatedir}"
OPKGLIBDIR = "${target_localstatedir}/lib"
@@ -64,7 +60,7 @@ do_install_append () {
# We need to create the lock directory
install -d ${D}${OPKGLIBDIR}/opkg
- if ${@bb.utils.contains('DISTRO_FEATURES','sysvinit','false','true',d)};then
+ if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)};then
install -d ${D}${systemd_unitdir}/system
install -m 0644 ${WORKDIR}/opkg-configure.service ${D}${systemd_unitdir}/system/
sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \