aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorWolfgang Denk <wd@denx.de>2014-11-05 20:29:51 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-11-25 11:39:44 +0000
commit477ca2da14abaf072d3645c4be916760a48b8938 (patch)
tree500344d49d69ee5428320d14ea469555f40ae02d /meta/recipes-devtools
parent131a17f014e6373dae526cc927588ccc0fedc38d (diff)
downloadopenembedded-core-contrib-477ca2da14abaf072d3645c4be916760a48b8938.tar.gz
perl: fix PERL5LIB settings
The PERL5LIB settings in the perl wrapper script did not include the "site_perl" or "vendor_perl" directories, which caused some errors. See https://bugzilla.yoctoproject.org/show_bug.cgi?id=6890 Signed-off-by: Wolfgang Denk <wd@denx.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/perl/perl-native_5.20.0.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-devtools/perl/perl-native_5.20.0.bb b/meta/recipes-devtools/perl/perl-native_5.20.0.bb
index 069696ae0c..01d40fcff2 100644
--- a/meta/recipes-devtools/perl/perl-native_5.20.0.bb
+++ b/meta/recipes-devtools/perl/perl-native_5.20.0.bb
@@ -103,8 +103,8 @@ do_install () {
install $i ${D}${libdir}/perl/${PV}/CORE
done
- create_wrapper ${D}${bindir}/perl PERL5LIB='$PERL5LIB:${STAGING_LIBDIR}/perl/${PV}:${STAGING_LIBDIR}/perl/'
- create_wrapper ${D}${bindir}/perl${PV} PERL5LIB='$PERL5LIB:${STAGING_LIBDIR}/perl/${PV}:${STAGING_LIBDIR}/perl/'
+ create_wrapper ${D}${bindir}/perl PERL5LIB='$PERL5LIB:${STAGING_LIBDIR}/perl/${PV}:${STAGING_LIBDIR}/perl:${STAGING_LIBDIR}/perl/site_perl/${PV}:${STAGING_LIBDIR}/perl/vendor_perl/${PV}'
+ create_wrapper ${D}${bindir}/perl${PV} PERL5LIB='$PERL5LIB:${STAGING_LIBDIR}/perl/${PV}:${STAGING_LIBDIR}/perl${STAGING_LIBDIR}/perl:${STAGING_LIBDIR}/perl/site_perl/${PV}:${STAGING_LIBDIR}/perl/vendor_perl/${PV}'
# Use /usr/bin/env nativeperl for the perl script.
for f in `grep -Il '#! *${bindir}/perl' ${D}/${bindir}/*`; do