aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-06-02 12:25:58 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-02 11:45:25 +0100
commit798db38f993cf9bad6feb2da6e0eea0a582ba9f3 (patch)
tree47bb120120815d8b375619e50015f27dc3a44e96 /meta/recipes-devtools
parentb03ebfaee278eb98b4bd0e11a682ac0cda192086 (diff)
downloadopenembedded-core-contrib-798db38f993cf9bad6feb2da6e0eea0a582ba9f3.tar.gz
python-docutils: move to Python 3
Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/python/python3-dbus_1.2.4.bb4
-rw-r--r--meta/recipes-devtools/python/python3-docutils_0.12.bb (renamed from meta/recipes-devtools/python/python-docutils_0.12.bb)4
2 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-devtools/python/python3-dbus_1.2.4.bb b/meta/recipes-devtools/python/python3-dbus_1.2.4.bb
index c058cafcf1..759512c396 100644
--- a/meta/recipes-devtools/python/python3-dbus_1.2.4.bb
+++ b/meta/recipes-devtools/python/python3-dbus_1.2.4.bb
@@ -15,8 +15,8 @@ S = "${WORKDIR}/dbus-python-${PV}"
inherit distutils3-base autotools pkgconfig
PACKAGECONFIG ?= ""
-PACKAGECONFIG[docs] = "--enable-html-docs,--disable-html-docs,python-docutils-native"
-PACKAGECONFIG[api-docs] = "--enable-api-docs,--disable-api-docs,python-docutils-native python-epydoc-native"
+PACKAGECONFIG[docs] = "--enable-html-docs,--disable-html-docs,python3-docutils-native"
+PACKAGECONFIG[api-docs] = "--enable-api-docs,--disable-api-docs,python3-docutils-native python3-epydoc-native"
do_configure_prepend() {
export PYTHON=${PYTHON}
diff --git a/meta/recipes-devtools/python/python-docutils_0.12.bb b/meta/recipes-devtools/python/python3-docutils_0.12.bb
index 8cda88d277..e78fa3bbc8 100644
--- a/meta/recipes-devtools/python/python-docutils_0.12.bb
+++ b/meta/recipes-devtools/python/python3-docutils_0.12.bb
@@ -4,7 +4,7 @@ SECTION = "devel/python"
LICENSE = "PSF & BSD-2-Clause & GPLv3"
LIC_FILES_CHKSUM = "file://COPYING.txt;md5=a722fbdc20347db7b69223594dd54574"
-DEPENDS = "python"
+DEPENDS = "python3"
SRC_URI = "${SOURCEFORGE_MIRROR}/docutils/docutils-${PV}.tar.gz"
SRC_URI[md5sum] = "4622263b62c5c771c03502afa3157768"
@@ -12,7 +12,7 @@ SRC_URI[sha256sum] = "c7db717810ab6965f66c8cf0398a98c9d8df982da39b4cd7f162911eb8
S = "${WORKDIR}/docutils-${PV}"
-inherit distutils
+inherit distutils3
BBCLASSEXTEND = "native"