aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/valgrind
diff options
context:
space:
mode:
authorDave Lerner <dave.lerner@windriver.com>2015-08-17 14:55:56 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-08-19 18:05:37 +0100
commit3898cc33d155ca28bd0bfea614e92a9b87c726bb (patch)
treea08578dd36c14651ab943e8196569e23067ce852 /meta/recipes-devtools/valgrind
parentc8b8749073dfc7c65fc0885601dbf7e40922d74d (diff)
downloadopenembedded-core-contrib-3898cc33d155ca28bd0bfea614e92a9b87c726bb.tar.gz
valgrind: build ptests without optimizations
This commit changes the both CFLAGS and CXXFLAGS when building the valgrind ptest binaries by appending -O0, forcing no optimizations instead of the default -O2. For qemux86-64, this change results in FAIL/PASS ratio improvements from 149/394 to 58/485. It is evident that the expected result files were generated from regression tests binaries built without optimizations. [ YOCTO #8063 ] (From OE-Core rev: 98c4a3ffb8dca10739be600e8d6df7fb6aa4958f) Signed-off-by: Dave Lerner <dave.lerner@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/valgrind')
-rw-r--r--meta/recipes-devtools/valgrind/valgrind_3.10.1.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/valgrind/valgrind_3.10.1.bb b/meta/recipes-devtools/valgrind/valgrind_3.10.1.bb
index 97d923d6f0..537d7c8b93 100644
--- a/meta/recipes-devtools/valgrind/valgrind_3.10.1.bb
+++ b/meta/recipes-devtools/valgrind/valgrind_3.10.1.bb
@@ -57,7 +57,7 @@ RRECOMMENDS_${PN} += "${TCLIBC}-dbg"
RDEPENDS_${PN}-ptest += " sed perl glibc-utils perl-module-file-glob"
do_compile_ptest() {
- oe_runmake check
+ oe_runmake check CFLAGS="${CFLAGS} -O0" CXXFLAGS="${CXXFLAGS} -O0"
}