aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/valgrind/valgrind/remove-ppc-tests-failing-build.patch
diff options
context:
space:
mode:
authorDave Lerner <dave.lerner@windriver.com>2014-02-15 09:27:31 -0600
committerSaul Wold <sgw@linux.intel.com>2014-02-20 20:06:22 -0800
commitd4438e421f448cdb7e25c038d657bbebc1b6486e (patch)
tree87433e9b5b32f527a6493aa7c8e4356bb997765f /meta/recipes-devtools/valgrind/valgrind/remove-ppc-tests-failing-build.patch
parent43ac6e3216c5d985d6f90a28e727e397df616267 (diff)
downloadopenembedded-core-contrib-d4438e421f448cdb7e25c038d657bbebc1b6486e.tar.gz
valgrind: integration of regression tests to ptest
Modifies valgrind's regression test framework to be compatible with the yocto PTEST framework as follows: * existing recipe valgrind*bb adds new methods: do_compile_ptest and do_install_ptest. * new file run-ptest adds the wrapper interface to the valgrind regression test script vg_regtest. * existing valgrind regression test script 'vg_regtest' changes to report the status of the valgrind component tests in the format that PTEST expects, instead of the valgrind formats, but only when vg_regtest is invoked with an optional --yocto-ptest argument * four new patches disable building tests that don't compile with the yocto compiler and default options. See the patches for details. Signed-off-by: Dave Lerner <dave.lerner@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/valgrind/valgrind/remove-ppc-tests-failing-build.patch')
-rw-r--r--meta/recipes-devtools/valgrind/valgrind/remove-ppc-tests-failing-build.patch75
1 files changed, 75 insertions, 0 deletions
diff --git a/meta/recipes-devtools/valgrind/valgrind/remove-ppc-tests-failing-build.patch b/meta/recipes-devtools/valgrind/valgrind/remove-ppc-tests-failing-build.patch
new file mode 100644
index 0000000000..2a14e1852c
--- /dev/null
+++ b/meta/recipes-devtools/valgrind/valgrind/remove-ppc-tests-failing-build.patch
@@ -0,0 +1,75 @@
+Remove test apps not building with ppc and PTEST
+
+For mpc8316-rdb in none/tests/ppc32, the oe compiler options are
+inconsistent with the imposed test compiler options generating errors
+as follows:
+test_isa_2_07_part1
+test_isa_2_07_part2
+test_tm
+test_touch_tm
+ : unrecognized command line option '-mhtm'
+
+jm-insns
+testVMX
+ : AltiVec not supported in this target
+
+For the following tests, their inline assembler is inconsistent with
+the ppce300c3 variant:
+round.c:393
+power5+_round.c:98
+ : impossible constraint in 'asm'
+
+For the following tests, with both mpc8316-rdb and with qemuppc bsp,
+the inline assember is inconsistent with the oe compiler machine
+tuning:
+In memcheck/tests/ppc32
+ power_ISA2_05.c:56
+In none/tests/ppc32
+ test_dfp1.c:85
+ test_dfp2.c:160
+ test_dfp3.c:157
+ test_dfp4.c:73
+ test_dfp5.c:73
+ : impossible constraint in 'asm'
+
+Upstream-Status: Pending
+
+Signed-off-by: Dave Lerner <dave.lerner@windriver.com>
+
+diff --git a/memcheck/tests/ppc32/Makefile.am b/memcheck/tests/ppc32/Makefile.am
+index bd70eea..1436e8e 100644
+--- a/memcheck/tests/ppc32/Makefile.am
++++ b/memcheck/tests/ppc32/Makefile.am
+@@ -7,8 +7,7 @@ EXTRA_DIST = $(noinst_SCRIPTS) \
+ power_ISA2_05.stderr.exp power_ISA2_05.stdout.exp power_ISA2_05.vgtest \
+ power_ISA2_05.stdout.exp_Without_FPPO
+
+-check_PROGRAMS = \
+- power_ISA2_05
++check_PROGRAMS =
+
+ power_ISA2_05_CFLAGS = $(AM_CFLAGS) $(WERROR) -Winline -Wall -Wshadow -g \
+ -I$(top_srcdir)/include @FLAG_M32@
+diff --git a/none/tests/ppc32/Makefile.am b/none/tests/ppc32/Makefile.am
+index 4f581b6..91ce7e7 100644
+--- a/none/tests/ppc32/Makefile.am
++++ b/none/tests/ppc32/Makefile.am
+@@ -50,16 +50,8 @@ check_PROGRAMS = \
+ allexec \
+ bug129390-ppc32 \
+ bug139050-ppc32 \
+- ldstrev lsw jm-insns mftocrf mcrfs round test_fx test_gx \
+- testVMX twi tw xlc_dbl_u32 power5+_round power6_bcmp \
+- test_isa_2_06_part1 \
+- test_isa_2_06_part2 \
+- test_isa_2_06_part3 \
+- test_dfp1 test_dfp2 test_dfp3 test_dfp4 test_dfp5 \
+- test_isa_2_07_part1 \
+- test_isa_2_07_part2 \
+- test_tm \
+- test_touch_tm
++ ldstrev lsw mftocrf mcrfs test_fx test_gx \
++ twi tw xlc_dbl_u32 power6_bcmp
+
+ AM_CFLAGS += @FLAG_M32@
+ AM_CXXFLAGS += @FLAG_M32@