aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/valgrind/valgrind/force-nostabs.patch
diff options
context:
space:
mode:
authorDave Lerner <dave.lerner@windriver.com>2014-02-15 09:27:31 -0600
committerSaul Wold <sgw@linux.intel.com>2014-02-20 20:06:22 -0800
commitd4438e421f448cdb7e25c038d657bbebc1b6486e (patch)
tree87433e9b5b32f527a6493aa7c8e4356bb997765f /meta/recipes-devtools/valgrind/valgrind/force-nostabs.patch
parent43ac6e3216c5d985d6f90a28e727e397df616267 (diff)
downloadopenembedded-core-contrib-d4438e421f448cdb7e25c038d657bbebc1b6486e.tar.gz
valgrind: integration of regression tests to ptest
Modifies valgrind's regression test framework to be compatible with the yocto PTEST framework as follows: * existing recipe valgrind*bb adds new methods: do_compile_ptest and do_install_ptest. * new file run-ptest adds the wrapper interface to the valgrind regression test script vg_regtest. * existing valgrind regression test script 'vg_regtest' changes to report the status of the valgrind component tests in the format that PTEST expects, instead of the valgrind formats, but only when vg_regtest is invoked with an optional --yocto-ptest argument * four new patches disable building tests that don't compile with the yocto compiler and default options. See the patches for details. Signed-off-by: Dave Lerner <dave.lerner@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/valgrind/valgrind/force-nostabs.patch')
-rw-r--r--meta/recipes-devtools/valgrind/valgrind/force-nostabs.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta/recipes-devtools/valgrind/valgrind/force-nostabs.patch b/meta/recipes-devtools/valgrind/valgrind/force-nostabs.patch
new file mode 100644
index 0000000000..b644348bbc
--- /dev/null
+++ b/meta/recipes-devtools/valgrind/valgrind/force-nostabs.patch
@@ -0,0 +1,42 @@
+Suppress building ptest apps with the -gstabs option
+
+Force the configure tests for -gstabs compiler support to fail so that
+the regression tests don't try to build with the -gstabs option.
+Otherwise, the valgrind build when ptest is enabled fails with the
+error:
+ Stabs debuginfo not supported:
+ ../package/usr/lib/valgrind/ptest/memcheck/tests/deep_templates
+ ERROR: Function failed: split_and_strip_files
+
+Upstream-status: Inappropriate [gstabs support is appropriate upstream,
+ but not for this distro]
+
+Signed-off-by: Dave Lerner <dave.lerner@windriver.com>
+
+diff --git a/configure.ac b/configure.ac
+index 755dfb9..cc8b5e1 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1743,22 +1743,7 @@ AM_CONDITIONAL(DWARF4, test x$ac_have_dwarf4 = xyes)
+ CFLAGS=$safe_CFLAGS
+
+
+-# does this compiler support -gstabs ?
+-
+-AC_MSG_CHECKING([if gcc accepts -gstabs])
+-
+-safe_CFLAGS=$CFLAGS
+-CFLAGS="-gstabs"
+-AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]], [[
+- return 0;
+-]])], [
+-ac_have_gstabs=yes
+-AC_MSG_RESULT([yes])
+-], [
+ ac_have_gstabs=no
+-AC_MSG_RESULT([no])
+-])
+-CFLAGS=$safe_CFLAGS
+ AM_CONDITIONAL([HAVE_GSTABS], [test x$ac_have_gstabs = xyes])
+
+