aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/tcltk
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2013-06-20 21:38:25 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-06-20 15:12:03 +0100
commitc6386c8661f18f6b9104c74345120a56e2330ea4 (patch)
tree9542ccb0260441ec44085387413f9c04cb4238e1 /meta/recipes-devtools/tcltk
parentec06d828d8ee623b0064713583344db84496ef1e (diff)
downloadopenembedded-core-contrib-c6386c8661f18f6b9104c74345120a56e2330ea4.tar.gz
tcl: fix unit test boundary year issue
Unit test clock.test check the boundary year 2099 which is not inclusive. Include 2099 to be a valide year number. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/tcltk')
-rw-r--r--meta/recipes-devtools/tcltk/tcl/let-DST-include-year-2099.patch35
-rw-r--r--meta/recipes-devtools/tcltk/tcl_8.6.0.bb3
2 files changed, 37 insertions, 1 deletions
diff --git a/meta/recipes-devtools/tcltk/tcl/let-DST-include-year-2099.patch b/meta/recipes-devtools/tcltk/tcl/let-DST-include-year-2099.patch
new file mode 100644
index 0000000000..eef18128e1
--- /dev/null
+++ b/meta/recipes-devtools/tcltk/tcl/let-DST-include-year-2099.patch
@@ -0,0 +1,35 @@
+From f10135df3f4751d7c83a66561c988ae799b6372f Mon Sep 17 00:00:00 2001
+From: "Song.Li" <Song.Li@windriver.com>
+Date: Fri, 10 Aug 2012 13:07:20 +0800
+Subject: [PATCH] let DST include year 2099
+
+tcl puts Daylight Saving Time in deffect from 1916 to 2099,
+it should include the year 2099,becuase tcl
+self-contained testing have a DST testcase on 2099.
+so the condition statement "<2099" should be "<=2099"
+
+Upstream-Status: Submitted
+
+Signed-off-by: Song.Li <Song.Li@windriver.com>
+Signed-off-by: Kai Kang <kai.kang@windriver.com>
+
+---
+ library/clock.tcl | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/library/clock.tcl b/library/clock.tcl
+index 2e9cae7..e8efe4a 100644
+--- a/library/clock.tcl
++++ b/library/clock.tcl
+@@ -3945,7 +3945,7 @@ proc ::tcl::clock::ProcessPosixTimeZone { z } {
+
+ # Put DST in effect in all years from 1916 to 2099.
+
+- for { set y 1916 } { $y < 2099 } { incr y } {
++ for { set y 1916 } { $y <= 2099 } { incr y } {
+ set startTime [DeterminePosixDSTTime $z start $y]
+ incr startTime [expr { - wide($stdOffset) }]
+ set endTime [DeterminePosixDSTTime $z end $y]
+--
+1.7.9.5
+
diff --git a/meta/recipes-devtools/tcltk/tcl_8.6.0.bb b/meta/recipes-devtools/tcltk/tcl_8.6.0.bb
index 95556e2a64..7273182720 100644
--- a/meta/recipes-devtools/tcltk/tcl_8.6.0.bb
+++ b/meta/recipes-devtools/tcltk/tcl_8.6.0.bb
@@ -18,7 +18,8 @@ SRC_URI = "${BASE_SRC_URI} \
file://fix_non_native_build_issue.patch \
file://fix_issue_with_old_distro_glibc.patch \
file://no_packages.patch \
- file://tcl-remove-hardcoded-install-path.patch"
+ file://tcl-remove-hardcoded-install-path.patch \
+ file://let-DST-include-year-2099.patch;patchdir=.. "
SRC_URI[md5sum] = "573aa5fe678e9185ef2b3c56b24658d3"
SRC_URI[sha256sum] = "354422b9c4791685499123b2dfe01faa98b555c08906c010cb4449ddc75dcade"