aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/tcltk
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2012-08-06 15:05:44 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-06 14:07:01 +0100
commit7a97abb3f1c2ff8fd2dc7c59f866430cf99ab82d (patch)
tree73c5b4cacf6f2c10234e5b14f80acb605d6bf819 /meta/recipes-devtools/tcltk
parente6fb5a25a098bd639be4b176f58e552404232c93 (diff)
downloadopenembedded-core-contrib-7a97abb3f1c2ff8fd2dc7c59f866430cf99ab82d.tar.gz
tcl: Add ${bindir_crossscripts}/tclConfig.sh to sysroot stage
tclConfig.sh is changed in do_install for cross compile and is installed to STAGING_BINDIR_CROSS, but if SSTATE_DIR is set and tcl is from sstage, tclConfig.sh can't be found in STAGING_BINDIR_CROSS, add ${bindir_crossscripts}/tclConfig.sh to sysroot stage can fix it. [YOCTO #2891] Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/tcltk')
-rw-r--r--meta/recipes-devtools/tcltk/tcl_8.5.11.bb9
1 files changed, 7 insertions, 2 deletions
diff --git a/meta/recipes-devtools/tcltk/tcl_8.5.11.bb b/meta/recipes-devtools/tcltk/tcl_8.5.11.bb
index d5cf6dc167..f19e25a7de 100644
--- a/meta/recipes-devtools/tcltk/tcl_8.5.11.bb
+++ b/meta/recipes-devtools/tcltk/tcl_8.5.11.bb
@@ -49,8 +49,8 @@ do_install() {
#sed -i "s+${WORKDIR}+${STAGING_INCDIR}+g" tclConfig.sh
sed -i "s,-L${libdir},-L=${libdir},g" tclConfig.sh
sed -i "s,-I${includedir},-I=${includedir},g" tclConfig.sh
- install -d ${STAGING_BINDIR_CROSS}/
- install -m 0755 tclConfig.sh ${STAGING_BINDIR_CROSS}
+ install -d ${D}${bindir_crossscripts}
+ install -m 0755 tclConfig.sh ${D}${bindir_crossscripts}
cd ..
for dir in compat generic unix
do
@@ -59,6 +59,11 @@ do_install() {
done
}
+SYSROOT_PREPROCESS_FUNCS += "tcl_sysroot_preprocess"
+tcl_sysroot_preprocess () {
+ sysroot_stage_dir ${D}${bindir_crossscripts} ${SYSROOT_DESTDIR}${bindir_crossscripts}
+}
+
PACKAGES =+ "tcl-lib"
FILES_tcl-lib = "${libdir}/libtcl8.5.so*"
FILES_${PN} += "${prefix}/lib/tcl8.5 ${prefix}/lib/tcl8"