aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/tcltk
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2013-03-23 11:14:17 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-23 18:09:54 +0000
commit41c0241a810f0a97ddc98a834e717645e0047958 (patch)
tree804ae3e38be344e623c1f6eab05e2073d4245906 /meta/recipes-devtools/tcltk
parent1944d362866fef1af406ed50955f1ed7cd9c29a8 (diff)
downloadopenembedded-core-contrib-41c0241a810f0a97ddc98a834e717645e0047958.tar.gz
tcl: Fix the location of the installed headers
Having '${S}' in the for loop was causing the headers to be installed into the wrong location. Move the 'S' to the install line. Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/tcltk')
-rw-r--r--meta/recipes-devtools/tcltk/tcl_8.5.13.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-devtools/tcltk/tcl_8.5.13.bb b/meta/recipes-devtools/tcltk/tcl_8.5.13.bb
index 01fe36dc97..be9c61bf34 100644
--- a/meta/recipes-devtools/tcltk/tcl_8.5.13.bb
+++ b/meta/recipes-devtools/tcltk/tcl_8.5.13.bb
@@ -52,10 +52,10 @@ do_install() {
install -d ${D}${bindir_crossscripts}
install -m 0755 tclConfig.sh ${D}${bindir_crossscripts}
cd ..
- for dir in ${S}/../compat ${S}/../generic ${S}/../unix
+ for dir in compat generic unix
do
install -d ${D}${includedir}/tcl${PV}/$dir
- install -m 0644 $dir/*.h ${D}${includedir}/tcl${PV}/$dir/
+ install -m 0644 ${S}/../$dir/*.h ${D}${includedir}/tcl${PV}/$dir/
done
}