aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/tcltk
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2013-12-05 08:26:20 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-12-05 16:48:17 +0000
commit300760193c6bcfd20f1d4908f912bebd53e86281 (patch)
tree80a882c6ab949229c4e09cafaeea4110ab9ea9cf /meta/recipes-devtools/tcltk
parent1a61a104c29b001f0c1f52534c4a9a9d12d69bbb (diff)
downloadopenembedded-core-contrib-300760193c6bcfd20f1d4908f912bebd53e86281.tar.gz
tcl: fix tclConfig.sh to point to the correct private headers
When building expect with rm_work enabled, it was not finding the correct private header files because they were removed from the WORKDIR, this fixes the tclConfig.sh to point to the sysroot private area instead. This also fixes the -L directory to point to STAGING_LIBDIR instead if INCDIR! [YOCTO #5620] Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/tcltk')
-rw-r--r--meta/recipes-devtools/tcltk/tcl_8.6.1.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-devtools/tcltk/tcl_8.6.1.bb b/meta/recipes-devtools/tcltk/tcl_8.6.1.bb
index 10186c43d6..0d6468a38c 100644
--- a/meta/recipes-devtools/tcltk/tcl_8.6.1.bb
+++ b/meta/recipes-devtools/tcltk/tcl_8.6.1.bb
@@ -48,11 +48,13 @@ do_compile_prepend() {
do_install() {
autotools_do_install install-private-headers
ln -sf ./tclsh${VER} ${D}${bindir}/tclsh
+ sed -i "s+-L${B}+-L${STAGING_LIBDIR}+g" tclConfig.sh
sed -i "s+${WORKDIR}+${STAGING_INCDIR}+g" tclConfig.sh
sed -i "s,-L${libdir},-L=${libdir},g" tclConfig.sh
sed -i "s,-I${includedir},-I=${includedir},g" tclConfig.sh
install -d ${D}${bindir_crossscripts}
install -m 0755 tclConfig.sh ${D}${bindir_crossscripts}
+ install -m 0755 tclConfig.sh ${D}${libdir}
cd ..
for dir in compat generic unix
do