summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/tcltk
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2019-12-21 14:19:35 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-12-30 23:38:12 +0000
commit47df8c0dd8ff86af97e6c6d217fb8d69ebec24e5 (patch)
treecddb7df53dde0043b9efa2423ec513fb6662b3f5 /meta/recipes-devtools/tcltk
parentf0f766160663407ea7683d31bbf5f011accc9ba2 (diff)
downloadopenembedded-core-contrib-47df8c0dd8ff86af97e6c6d217fb8d69ebec24e5.tar.gz
perl/tcl: fix /usr/share/man/man3/Thread.3 conflicts
While installing perl-doc and tcl-doc to image, there is a file conflicts at do_rootfs ... |file /usr/share/man/man3/Thread.3 conflicts between attempted installs of perl-doc-5.30.1-r0.core2_64 and tcl-doc-8.6.10-r0.core2_64 ... Use update-alternatives to fix Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/tcltk')
-rw-r--r--meta/recipes-devtools/tcltk/tcl_8.6.10.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-devtools/tcltk/tcl_8.6.10.bb b/meta/recipes-devtools/tcltk/tcl_8.6.10.bb
index 284f20e27a..aedd96b021 100644
--- a/meta/recipes-devtools/tcltk/tcl_8.6.10.bb
+++ b/meta/recipes-devtools/tcltk/tcl_8.6.10.bb
@@ -34,7 +34,7 @@ S = "${WORKDIR}/${BPN}${PV}/unix"
VER = "${PV}"
-inherit autotools ptest binconfig
+inherit autotools ptest binconfig update-alternatives
EXTRA_OECONF = "--enable-threads --disable-rpath --libdir=${libdir}"
@@ -65,6 +65,9 @@ FILES_tcl-lib = "${libdir}/libtcl8.6.so.*"
FILES_${PN} += "${libdir}/tcl${VER} ${libdir}/tcl8.6 ${libdir}/tcl8"
FILES_${PN}-dev += "${libdir}/tclConfig.sh ${libdir}/tclooConfig.sh"
+ALTERNATIVE_${PN}-doc = "Thread.3"
+ALTERNATIVE_LINK_NAME[Thread.3] = "${mandir}/man3/Thread.3"
+
# isn't getting picked up by shlibs code
RDEPENDS_${PN} += "tcl-lib"
RDEPENDS_${PN}_class-native = ""