aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/tcltk/tcl/alter-includedir.patch
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2013-11-11 20:07:15 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-11-20 14:02:53 +0000
commit67f44193135c789e478410347ff58ed110ed9484 (patch)
treec244e4b1a3e3e09c043cb984704cce51460a2614 /meta/recipes-devtools/tcltk/tcl/alter-includedir.patch
parentd3caab6eb03264b4f4d744f914598022299011ba (diff)
downloadopenembedded-core-contrib-67f44193135c789e478410347ff58ed110ed9484.tar.gz
tcl: Install header into 8.6 instead of PN-PV in user/include
This helps in compiling other programs like expect which depend on private headers but 8.5, 8.6 and so on is enough granularity and currently we had 8.6.x and so on which means that expect recipe will need to be touched whenever there is minor update of tcl. Additionally the encode creating symlink to shared object in patch and remove it from recipe Refresh patches after making changes to Configure.in we propertly generate configure and not patch is directly as was the case. Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/tcltk/tcl/alter-includedir.patch')
-rw-r--r--meta/recipes-devtools/tcltk/tcl/alter-includedir.patch46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-devtools/tcltk/tcl/alter-includedir.patch b/meta/recipes-devtools/tcltk/tcl/alter-includedir.patch
new file mode 100644
index 0000000000..f543910be9
--- /dev/null
+++ b/meta/recipes-devtools/tcltk/tcl/alter-includedir.patch
@@ -0,0 +1,46 @@
+Lets install the include header and private header files into
+usr/include/tcl8.6 when version of tcl is 8.6.x
+
+Upstream-Status: Inappropriate [Configuration Specific]
+
+Signed-off-by: Khem Raj <raj.khem@gmai.com>
+
+Index: unix/Makefile.in
+===================================================================
+--- unix.orig/Makefile.in 2013-11-11 01:00:36.431550403 -0800
++++ unix/Makefile.in 2013-11-11 01:05:09.587557282 -0800
+@@ -53,7 +53,7 @@
+ SCRIPT_INSTALL_DIR = $(INSTALL_ROOT)$(TCL_LIBRARY)
+
+ # Directory in which to install the include file tcl.h:
+-INCLUDE_INSTALL_DIR = $(INSTALL_ROOT)$(includedir)
++INCLUDE_INSTALL_DIR = $(INSTALL_ROOT)$(includedir)/tcl$(VERSION)
+
+ # Path to the private tcl header dir:
+ PRIVATE_INCLUDE_DIR = @PRIVATE_INCLUDE_DIR@
+Index: unix/configure.in
+===================================================================
+--- unix.orig/configure.in 2013-11-11 01:00:36.467550403 -0800
++++ unix/configure.in 2013-11-11 01:00:36.503550404 -0800
+@@ -791,7 +791,7 @@
+ eval "TCL_LIB_FILE=${TCL_LIB_FILE}"
+
+ TCL_LIBRARY='$(libdir)/tcl$(VERSION)'
+-PRIVATE_INCLUDE_DIR='$(includedir)'
++PRIVATE_INCLUDE_DIR='$(includedir)/tcl$(VERSION)'
+ HTML_DIR='$(DISTDIR)/html'
+
+ # Note: in the following variable, it's important to use the absolute
+Index: unix/configure
+===================================================================
+--- unix.orig/configure 2013-11-11 01:00:36.467550403 -0800
++++ unix/configure 2013-11-11 01:00:36.503550404 -0800
+@@ -19134,7 +19134,7 @@
+ eval "TCL_LIB_FILE=${TCL_LIB_FILE}"
+
+ TCL_LIBRARY='$(libdir)/tcl$(VERSION)'
+-PRIVATE_INCLUDE_DIR='$(includedir)'
++PRIVATE_INCLUDE_DIR='$(includedir)/tcl$(VERSION)'
+ HTML_DIR='$(DISTDIR)/html'
+
+ # Note: in the following variable, it's important to use the absolute