aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/systemd-bootchart/systemd-bootchart_230.bb
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2016-06-16 16:48:12 +0800
committerChen Qi <Qi.Chen@windriver.com>2016-06-24 17:38:08 +0800
commit8a793f73c743bdcf9ce5e73c0ad3154cdf948cb3 (patch)
tree51de6caa0ec6fdddaccef2bdb022d1ad64ac7162 /meta/recipes-devtools/systemd-bootchart/systemd-bootchart_230.bb
parent5e83066cfcef86ada628d2332e551e56cbb0f05b (diff)
downloadopenembedded-core-contrib-8a793f73c743bdcf9ce5e73c0ad3154cdf948cb3.tar.gz
systemd: upgrade to 230ChenQi/PU-20160624
Patches are rebased or removed for the latest version. Python testing scripts are removed for systemd-ptest as systemd is configured with '--without-python'. systemd-bootchart is now seprated from systemd, thus removing the related configuration items. And we add systemd-bootchart recipe. Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
Diffstat (limited to 'meta/recipes-devtools/systemd-bootchart/systemd-bootchart_230.bb')
-rw-r--r--meta/recipes-devtools/systemd-bootchart/systemd-bootchart_230.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-devtools/systemd-bootchart/systemd-bootchart_230.bb b/meta/recipes-devtools/systemd-bootchart/systemd-bootchart_230.bb
new file mode 100644
index 0000000000..f209354d43
--- /dev/null
+++ b/meta/recipes-devtools/systemd-bootchart/systemd-bootchart_230.bb
@@ -0,0 +1,27 @@
+LICENSE = "LGPLv2.1 & GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE.LGPL2.1;md5=4fbd65380cdd255951079008b364516c \
+ file://LICENSE.GPL2;md5=751419260aa954499f7abaabaa882bbe"
+
+SRC_URI = "git://github.com/systemd/systemd-bootchart.git;protocol=https"
+
+# Modify these as desired
+PV = "230+git${SRCPV}"
+SRCREV = "dcb246b46239259ec99b3c6e6ab7d27e1a5a8a84"
+
+S = "${WORKDIR}/git"
+
+DEPENDS = "systemd libxslt-native xmlto-native docbook-xml-dtd4-native docbook-xsl-stylesheets-native intltool"
+
+inherit pkgconfig autotools systemd
+
+SYSTEMD_SERVICE_${PN} = "systemd-bootchart.service"
+
+do_configure_prepend() {
+ # intltool.m4 is a soft link to /usr/share/aclocal/m4, delete it and use the one in our sysroot
+ rm -f ${S}/m4/intltool.m4
+}
+
+FILES_${PN} += "${systemd_unitdir}/systemd-bootchart"
+
+EXTRA_OECONF = " --with-rootprefix=${base_prefix} \
+ --with-rootlibdir=${base_libdir}"