aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/strace
diff options
context:
space:
mode:
authorKoen Kooi <koen.kooi@linaro.org>2015-04-15 14:32:37 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-04-19 13:34:03 +0100
commita40309f284805e8cda024f7299a676cfdf8f97a5 (patch)
tree047d297e5ae845322b85d2add61f3f4c92a7e19a /meta/recipes-devtools/strace
parent31d84f67f74b31b479409cfa446b14ac67bb3707 (diff)
downloadopenembedded-core-contrib-a40309f284805e8cda024f7299a676cfdf8f97a5.tar.gz
strace: fix build for aarch64
Upstream added aarch64 support but forgot to update 'make dist' leading to missing files in the tarball. Signed-off-by: Koen Kooi <koen.kooi@linaro.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/strace')
-rw-r--r--meta/recipes-devtools/strace/strace/0001-Add-linux-aarch64-arch_regs.h.patch25
-rw-r--r--meta/recipes-devtools/strace/strace_4.10.bb1
2 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-devtools/strace/strace/0001-Add-linux-aarch64-arch_regs.h.patch b/meta/recipes-devtools/strace/strace/0001-Add-linux-aarch64-arch_regs.h.patch
new file mode 100644
index 0000000000..f70766b646
--- /dev/null
+++ b/meta/recipes-devtools/strace/strace/0001-Add-linux-aarch64-arch_regs.h.patch
@@ -0,0 +1,25 @@
+From f85854131c8265f2eb59c714dcea5c4b3dc09bed Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen.kooi@linaro.org>
+Date: Wed, 15 Apr 2015 14:29:37 +0200
+Subject: [PATCH] Add linux/aarch64/arch_regs.h
+
+It is missing from the tarball, but it is present in git for v4.10
+
+Signed-off-by: Koen Kooi <koen.kooi@linaro.org>
+Upstream-status: Pending
+---
+ linux/aarch64/arch_regs.h | 2 ++
+ 1 file changed, 2 insertions(+)
+ create mode 100644 linux/aarch64/arch_regs.h
+
+diff --git a/linux/aarch64/arch_regs.h b/linux/aarch64/arch_regs.h
+new file mode 100644
+index 0000000..9a5e33e
+--- /dev/null
++++ b/linux/aarch64/arch_regs.h
+@@ -0,0 +1,2 @@
++extern uint64_t *const aarch64_sp_ptr;
++extern uint32_t *const arm_sp_ptr;
+--
+1.9.3
+
diff --git a/meta/recipes-devtools/strace/strace_4.10.bb b/meta/recipes-devtools/strace/strace_4.10.bb
index 416c38756a..707cb765c9 100644
--- a/meta/recipes-devtools/strace/strace_4.10.bb
+++ b/meta/recipes-devtools/strace/strace_4.10.bb
@@ -5,6 +5,7 @@ LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://COPYING;md5=124500c21e856f0912df29295ba104c7"
SRC_URI = "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.xz \
+ file://0001-Add-linux-aarch64-arch_regs.h.patch \
file://git-version-gen \
file://strace-add-configure-options.patch \
file://Makefile-ptest.patch \