aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/strace
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2013-06-21 16:12:21 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-06-21 13:24:44 +0100
commit9b6b7973a5e49fe9cd283c5b4af31e8a7940e7b5 (patch)
tree664defe143a8a9703f96b33e23ef90cfe3467fb4 /meta/recipes-devtools/strace
parent3ae2592b40900caaebe2452c875912f82f9e5200 (diff)
downloadopenembedded-core-contrib-9b6b7973a5e49fe9cd283c5b4af31e8a7940e7b5.tar.gz
strace: add configure options libaio and acl
Add strace configure options libaio and acl to enable or disable build with them. Then PACKAGECONFIG can be used to handle dependency. Set "libaio" as a default feature of PACKAGECONFIG. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/strace')
-rw-r--r--meta/recipes-devtools/strace/strace-4.8/strace-add-configure-options.patch60
-rw-r--r--meta/recipes-devtools/strace/strace_4.8.bb9
2 files changed, 68 insertions, 1 deletions
diff --git a/meta/recipes-devtools/strace/strace-4.8/strace-add-configure-options.patch b/meta/recipes-devtools/strace/strace-4.8/strace-add-configure-options.patch
new file mode 100644
index 0000000000..27266d9052
--- /dev/null
+++ b/meta/recipes-devtools/strace/strace-4.8/strace-add-configure-options.patch
@@ -0,0 +1,60 @@
+Add options "aio" and "acl" to enable/disable libaio and acl support.
+
+Upstream-Status: Pending
+
+Signed-off-by: Kai Kang <kai.kang@windriver.com>
+
+--- strace-4.8/configure.ac.orig 2013-06-21 15:37:52.145892182 +0800
++++ strace-4.8/configure.ac 2013-06-21 15:45:49.029909004 +0800
+@@ -219,7 +219,6 @@ AC_CHECK_HEADERS(m4_normalize([
+ netinet/sctp.h
+ poll.h
+ stropts.h
+- sys/acl.h
+ sys/asynch.h
+ sys/conf.h
+ sys/epoll.h
+@@ -231,6 +230,19 @@ AC_CHECK_HEADERS(m4_normalize([
+ sys/uio.h
+ sys/vfs.h
+ ]))
++
++AC_ARG_ENABLE([acl],
++ [AS_HELP_STRING([--enable-acl], [turn on acl support])],
++ [case $enableval in
++ yes)
++ AC_CHECK_HEADERS([sys/acl.h])
++ ;;
++ no) ;;
++ *) AC_MSG_ERROR([bad value $enableval for aio option]) ;;
++ esac]
++
++)
++
+ AC_CHECK_HEADERS([linux/icmp.h linux/in6.h linux/netlink.h linux/if_packet.h],
+ [], [], [#include <stddef.h>
+ #include <sys/socket.h>
+@@ -301,10 +313,19 @@ AC_CHECK_SIZEOF([long])
+ AC_CHECK_SIZEOF([long long])
+ AC_CHECK_SIZEOF([rlim_t],,[#include <sys/resource.h>])
+
+-AC_CHECK_HEADERS([libaio.h], [
+- AC_CHECK_MEMBERS([struct iocb.u.c.flags],,, [#include <libaio.h>])
+- AC_CHECK_DECLS([IO_CMD_PWRITE, IO_CMD_PWRITEV],,, [#include <libaio.h>])
+-])
++AC_ARG_ENABLE([aio],
++ [AS_HELP_STRING([--enable-aio], [turn on libaio support])],
++ [case $enableval in
++ yes)
++ AC_CHECK_HEADERS([libaio.h], [
++ AC_CHECK_MEMBERS([struct iocb.u.c.flags],,, [#include <libaio.h>])
++ AC_CHECK_DECLS([IO_CMD_PWRITE, IO_CMD_PWRITEV],,, [#include <libaio.h>])
++ ])
++ ;;
++ no) ;;
++ *) AC_MSG_ERROR([bad value $enableval for aio option]) ;;
++ esac]
++)
+
+ AC_PATH_PROG([PERL], [perl])
+
diff --git a/meta/recipes-devtools/strace/strace_4.8.bb b/meta/recipes-devtools/strace/strace_4.8.bb
index c1ffdd1270..0f4d2f001e 100644
--- a/meta/recipes-devtools/strace/strace_4.8.bb
+++ b/meta/recipes-devtools/strace/strace_4.8.bb
@@ -6,12 +6,19 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=124500c21e856f0912df29295ba104c7"
PR = "r0"
SRC_URI = "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.xz \
- file://git-version-gen"
+ file://git-version-gen \
+ file://strace-add-configure-options.patch"
SRC_URI[md5sum] = "c575ef43829586801f514fd91bfe7575"
SRC_URI[sha256sum] = "f492291f07a7c805c07a8395cce1ea054a6401ad414f4cc12185672215e1d7f8"
inherit autotools
+PACKAGECONFIG_class-target ?= "libaio"
+PACKAGECONFIG_class-target += "${@base_contains('DISTRO_FEATURES', 'acl', 'acl', '', d)}"
+
+PACKAGECONFIG[libaio] = "--enable-aio,--disable-aio,libaio"
+PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl"
+
export INCLUDES = "-I. -I./linux"
do_configure_prepend() {