aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/strace/strace_4.8.bb
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2013-06-21 16:12:21 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-06-21 13:24:49 +0100
commit302a039cda0b4dc8829844c15db846f055424f8b (patch)
treeeee93b3b01c96cfb9e1c958475565160518e8fcf /meta/recipes-devtools/strace/strace_4.8.bb
parent4e5ba5f88285e94de4b78399306b07e0b57e7f03 (diff)
downloadopenembedded-core-contrib-302a039cda0b4dc8829844c15db846f055424f8b.tar.gz
strace: add configure options libaio and acl
Add strace configure options libaio and acl to enable or disable build with them. Then PACKAGECONFIG can be used to handle dependency. Set "libaio" as a default feature of PACKAGECONFIG. (From OE-Core rev: 9b6b7973a5e49fe9cd283c5b4af31e8a7940e7b5) Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/strace/strace_4.8.bb')
-rw-r--r--meta/recipes-devtools/strace/strace_4.8.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/meta/recipes-devtools/strace/strace_4.8.bb b/meta/recipes-devtools/strace/strace_4.8.bb
index c1ffdd1270..0f4d2f001e 100644
--- a/meta/recipes-devtools/strace/strace_4.8.bb
+++ b/meta/recipes-devtools/strace/strace_4.8.bb
@@ -6,12 +6,19 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=124500c21e856f0912df29295ba104c7"
PR = "r0"
SRC_URI = "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.xz \
- file://git-version-gen"
+ file://git-version-gen \
+ file://strace-add-configure-options.patch"
SRC_URI[md5sum] = "c575ef43829586801f514fd91bfe7575"
SRC_URI[sha256sum] = "f492291f07a7c805c07a8395cce1ea054a6401ad414f4cc12185672215e1d7f8"
inherit autotools
+PACKAGECONFIG_class-target ?= "libaio"
+PACKAGECONFIG_class-target += "${@base_contains('DISTRO_FEATURES', 'acl', 'acl', '', d)}"
+
+PACKAGECONFIG[libaio] = "--enable-aio,--disable-aio,libaio"
+PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl"
+
export INCLUDES = "-I. -I./linux"
do_configure_prepend() {