summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/strace/strace_4.25.bb
diff options
context:
space:
mode:
authorMauno Niko <niko.mauno@vaisala.com>2018-11-12 11:32:14 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-11-13 15:18:28 +0000
commitfacb6e2fd887d526e031b6c16b4bb8d385db952a (patch)
tree7207119b206f9a1eef44549c9f3afcc7e2be78cf /meta/recipes-devtools/strace/strace_4.25.bb
parent9457163b2c4982a64814c6b38c292d7bc61ff643 (diff)
downloadopenembedded-core-contrib-facb6e2fd887d526e031b6c16b4bb8d385db952a.tar.gz
strace: Bump to version 4.25
V4L2_CID_USER_IMX_BASE value differs in v4.14 and v4.19 LTS kernels https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/tree/include/uapi/linux/v4l2-controls.h?h=v4.14.79#n191 https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/tree/include/uapi/linux/v4l2-controls.h?h=v4.19.1#n191 Building strace v4.24 against 4.19 kernel headers results in following build failure | arm-vaisala-linux-gnueabi-ranlib libstrace.a | In file included from ../strace-4.24/static_assert.h:31, | from ../strace-4.24/xlat/v4l2_pix_fmts.h:4, | from ../strace-4.24/v4l2.c:78: | ../strace-4.24/xlat/v4l2_control_id_bases.h:36:1: error: static assertion failed: "V4L2_CID_USER_IMX_BASE != (V4L2_CID_BASE + 0x1090)" This Linux kernel ABI breakage that occurred wrt V4L2_CID_USER_IMX_BASE has been observed and addressed in strace upstream commit https://github.com/strace/strace/commit/b89a69dec27cf638df0e17db80ed937c3e1abf77 Bump strace to version 4.25 which also addresses ABI breakage so that strace once again builds against both v4.14 and v4.19 LTS kernel headers Signed-off-by: Niko Mauno <niko.mauno@vaisala.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/strace/strace_4.25.bb')
-rw-r--r--meta/recipes-devtools/strace/strace_4.25.bb64
1 files changed, 64 insertions, 0 deletions
diff --git a/meta/recipes-devtools/strace/strace_4.25.bb b/meta/recipes-devtools/strace/strace_4.25.bb
new file mode 100644
index 0000000000..117ebfbf72
--- /dev/null
+++ b/meta/recipes-devtools/strace/strace_4.25.bb
@@ -0,0 +1,64 @@
+SUMMARY = "System call tracing tool"
+HOMEPAGE = "http://strace.io"
+SECTION = "console/utils"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://COPYING;md5=6ddb91734b9c705f3e87362e97e5f64b"
+
+SRC_URI = "https://strace.io/files/${PV}/strace-${PV}.tar.xz \
+ file://disable-git-version-gen.patch \
+ file://more-robust-test-for-m32-mx32-compile-support.patch \
+ file://update-gawk-paths.patch \
+ file://Makefile-ptest.patch \
+ file://run-ptest \
+ file://0001-Fix-build-when-using-non-glibc-libc-implementation-o.patch \
+ file://mips-SIGEMT.patch \
+ file://0001-caps-abbrev.awk-fix-gawk-s-path.patch \
+ file://0001-tests-sigaction-Check-for-mips-and-alpha-before-usin.patch \
+ "
+SRC_URI[md5sum] = "fa5ac841e9ce6af133061822898d49a9"
+SRC_URI[sha256sum] = "d685f8e65470b7832c3aff60c57ab4459f26ff89f07c10f92bd70ee89efac701"
+
+inherit autotools ptest bluetooth
+
+PACKAGECONFIG_class-target ??= "\
+ ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \
+"
+
+PACKAGECONFIG[bluez] = "ac_cv_header_bluetooth_bluetooth_h=yes,ac_cv_header_bluetooth_bluetooth_h=no,${BLUEZ}"
+PACKAGECONFIG[libunwind] = "--with-libunwind,--without-libunwind,libunwind"
+
+EXTRA_OECONF += "--enable-mpers=no"
+
+CFLAGS_append_libc-musl = " -Dsigcontext_struct=sigcontext"
+
+TESTDIR = "tests"
+
+do_install_append() {
+ # We don't ship strace-graph here because it needs perl
+ rm ${D}${bindir}/strace-graph
+}
+
+do_compile_ptest() {
+ oe_runmake -C ${TESTDIR} buildtest-TESTS
+}
+
+do_install_ptest() {
+ oe_runmake -C ${TESTDIR} install-ptest BUILDDIR=${B} DESTDIR=${D}${PTEST_PATH} TESTDIR=${TESTDIR}
+ install -m 755 ${S}/test-driver ${D}${PTEST_PATH}
+ install -m 644 ${B}/config.h ${D}${PTEST_PATH}
+ sed -i -e '/^src/s/strace.*[1-9]/ptest/' \
+ -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
+ -e 's|${DEBUG_PREFIX_MAP}||g' \
+ -e 's:${HOSTTOOLS_DIR}/::g' \
+ -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
+ -e 's:${RECIPE_SYSROOT}::g' \
+ -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \
+ -e '/^DEB_CHANGELOGTIME/d' \
+ -e '/^RPM_CHANGELOGTIME/d' \
+ ${D}/${PTEST_PATH}/${TESTDIR}/Makefile
+}
+
+RDEPENDS_${PN}-ptest += "make coreutils grep gawk sed"
+
+BBCLASSEXTEND = "native"
+TOOLCHAIN = "gcc"