aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/strace/strace/strace-add-configure-options.patch
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-04-07 04:24:22 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-04-07 17:32:01 +0100
commitaf76eb0405352d66dfd00d7f856f401d892855e1 (patch)
treefaa96b1c8e3240221200ae47216ec19465b66f95 /meta/recipes-devtools/strace/strace/strace-add-configure-options.patch
parent34d517a5626ce2465f776367349bd9e66bf8ed1f (diff)
downloadopenembedded-core-contrib-af76eb0405352d66dfd00d7f856f401d892855e1.tar.gz
strace: 4.9 -> 4.10
Updated patches: Makefile-ptest.patch strace-add-configure-options.patch Fixed: debugedit: netlink_unix_diag: canonicalization unexpectedly shrank by one character It was because oe_runmake -C ${TESTDIR} buildtest-TESTS didn't set OS and ARCH, which caused "-I<foo>//" in gcc options, and would cause debugedit error. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/strace/strace/strace-add-configure-options.patch')
-rw-r--r--meta/recipes-devtools/strace/strace/strace-add-configure-options.patch57
1 files changed, 57 insertions, 0 deletions
diff --git a/meta/recipes-devtools/strace/strace/strace-add-configure-options.patch b/meta/recipes-devtools/strace/strace/strace-add-configure-options.patch
new file mode 100644
index 0000000000..e48e4b31b9
--- /dev/null
+++ b/meta/recipes-devtools/strace/strace/strace-add-configure-options.patch
@@ -0,0 +1,57 @@
+Add options "aio" and "acl" to enable/disable libaio and acl support.
+
+Upstream-Status: Pending
+
+Signed-off-by: Kai Kang <kai.kang@windriver.com>
+Signed-off-by: Chong Lu <Chong.Lu@windriver.com>
+---
+ configure.ac | 26 ++++++++++++++++++++++++++
+ 1 file changed, 26 insertions(+)
+
+diff --git a/configure.ac b/configure.ac
+index e73958c..9099370 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -270,6 +270,18 @@ AC_CHECK_HEADERS(m4_normalize([
+ sys/vfs.h
+ sys/xattr.h
+ ]))
++
++AC_ARG_ENABLE([acl],
++ [AS_HELP_STRING([--enable-acl], [turn on acl support])],
++ [case $enableval in
++ yes)
++ AC_CHECK_HEADERS([sys/acl.h])
++ ;;
++ no) ;;
++ *) AC_MSG_ERROR([bad value $enableval for aio option]) ;;
++ esac]
++)
++
+ AC_CHECK_HEADERS([linux/icmp.h linux/in6.h linux/netlink.h linux/if_packet.h],
+ [], [], [#include <stddef.h>
+ #include <sys/socket.h>
+@@ -745,6 +757,20 @@ if test "x$ac_cv_lib_dl_dladdr" = xyes; then
+ fi
+ AC_SUBST(dl_LIBS)
+
++AC_ARG_ENABLE([aio],
++ [AS_HELP_STRING([--enable-aio], [turn on libaio support])],
++ [case $enableval in
++ yes)
++ AC_CHECK_HEADERS([libaio.h], [
++ AC_CHECK_MEMBERS([struct iocb.u.c.flags],,, [#include <libaio.h>])
++ AC_CHECK_DECLS([IO_CMD_PWRITE, IO_CMD_PWRITEV],,, [#include <libaio.h>])
++ ])
++ ;;
++ no) ;;
++ *) AC_MSG_ERROR([bad value $enableval for aio option]) ;;
++ esac]
++)
++
+ AC_PATH_PROG([PERL], [perl])
+
+ dnl stack trace with libunwind
+--
+1.9.1
+